How to create volume meter for input volume and output volume


#41

I use Reaper DAW so i use it as a .dll vst plugin.
I did have the same problem with several different meter implementations. It was the same even for the JUCE InterAppAudioTutorial so it is a general thing.
It is both hearable and noticable by the difference with the Reaper built-in meters.


#42

This is not a JUCE problem. (It’s probably just a coincidence if you saw a similar thing happening with something else that is JUCE based.) Reaper has the anticipative audio processing feature that prerenders the tracks ahead of time which makes the playing audio and plugin GUIs be out of sync. You can try lowering the anticipative rendering length, the default is pretty large, 200 milliseconds. (Preferences->Buffering->Render-ahead.) About 50 milliseconds can still have a benefit for the audio processing on multicore computers and the problem with the plugin GUIs will be less noticeable.

Reaper can of course implement its own track meters to deal with this, but for plugins there is no obvious solution that either the Reaper developers or the plugin developers could implement.

Even Cockos’s own plugins in Reaper (like ReaFIR) suffer from this issue. In this screen capture, I have set the render-ahead length to a ridiculous 5000 milliseconds to make the issue as clear as possible. The plugin’s analysis GUI is completely out of time, while the track level meter corresponds to what is currently playing.


#43

Thank you so much!!!
Reaper got me