How to enable Mono->Stereo option for plug-in within Logic

Hello,

I am trying to configure my plug-in to support a Mono->Stereo layout within Logic. However, when I load my plug-in within Logic on a mono channel, the only layout option is mono (and other plug-ins I’ve found will support mono->stereo).

I have set my Plugin Channel Configurations in the Projucer to {1,1},{1,2},{2,2}, and I have tested all three configurations in the AudioPluginHost and they work as expected. And yet, no option appears in Logic.

What steps should I take to enable this option? Many thanks!

We deleted the Plugin Channel Configurations entry, and instead have this code in the processor’s isBusesLayoutSupported():

if (layouts.getMainOutputChannelSet() == AudioChannelSet::mono())
{
	// Mono-to-mono
	if (layouts.getMainInputChannelSet() == AudioChannelSet::mono())
		return true;
}
else if (layouts.getMainOutputChannelSet() == AudioChannelSet::stereo())
{
	// Mono-to-stereo OR stereo-to-stereo
	if ((layouts.getMainInputChannelSet() == AudioChannelSet::mono()) ||
			(layouts.getMainInputChannelSet() == AudioChannelSet::stereo()))
		return true;
}
//
return false;

That seems to work fine for Logic and other hosts.

1 Like

I removed the Plugin Channel Configurations entry and inserted those lines of code as my isBusesLayoutSupported method, but Logic still did not provide the option to run the plugin with a mono->stereo layout (even after rescanning the plugin).

I did find that the AU validation output when using isBusesLayoutSupported is more verbose than using the Plugin Channel Configurations entry. However, both methods of setting the supported bus layouts indicated that 1-1, 1-2, and 2-2 was a supported layout (from the validation output).

Are there any other requirements necessary to support this bus layout beyond just indicating the layout is supported?

Did you reboot? I found I always had to reboot before the Mac would recognize that a plugin had changed its configuration in this manner.

1 Like

I did try rebooting (good idea!) but it did not fix it. That gave me another idea however: I hadn’t increased the version number at any point. As soon as I did, Logic recognized the mono->stereo layout.
Thanks for your help!

1 Like