iLok and Parallels

And while we’re speaking of Pace… :wink:

Anyone else having issues using a USB iLok dongle while running Windows on Parallels?

This used to work for me for a few years with no issues, and now, it won’t wrap…USB connection issue…but it works just fine on Mac.

I do it all day long – make sure that your Parallels sees the iLok(s) in ILM… and the Service is running.


If it still won’t wrap PM me


If you’re using Catalina make sure to give it rights in ‘full disk access’ in macOS security & privacy otherwise you may have USB sharing issues. I also turned off USB 3.0 support for the VM.

I also had a lot of troubles in parallels with my iLok 3. I had to remove and plug it in about 20 times until it worked for signing. It was detected and showed up, but it didn’t work for signing and also sync in the iLok manager was not possible on windows.

I moved only the the eden license i need for signing to a separate iLok (the older iLok 2 i still had) and now it works without any issues.

I’m not sure if the iLok 3 was the problem or a combination of the licenses on my iLok 3… i’m also interested in some more information about this.

Edit: Maybe it was the USB 3 support i still have enabled.

I’ve now tried turning off USB 3 support on 2 different Macs, running Parallels 14 & 15. The gear icon showed up just once(!) and it worked, but never again. Without the gear icon, it won’t wrap or sync. Full disk access is also checked. I’ll see what Pace says. In the mean time, I’ve ordered another iLok just to see if it’s the dongle. Damn…what a waste of time.

Consider setting up a support ticket with Parallels support. They went through things with me and got it working on my VM (the changes are what I shared with you). They may have other things they can try with you.

@pizzafilms Any luck fixing that issue? I’m running into this issue when trying to activate my Pro Tools Developer licence. I get the iLok sharing error in Windows when running in Parallels.

I opened up support tickets with both Pace and Parallels. So far, Pace concluded that it wasn’t their problem. Parallels support has had me try quite a few things, but nothing concrete so far. We’re still working on it.

The only things I’ve ruled out as a source of the issue are the iLok dongle itself (I purchased a second one without any difference), and several USB to USB-C adapters.

I’ll definitely report if and when an answer is found.

1 Like

Oh damn. The joys…

Dusting off the good old Windows laptop then!

I don’t think it’s an adapter issue. It makes no difference to my issues whether I am using the USB-A on the back of the iMac or the USB-A of an Intel certified Thunderbolt 3 dock.

Currently I have no problems routing one iLok through to a Windows 10 VM in Catalina, but as soon as I plug in a second iLok I cannot run one in Windows and one in Catalina at the same time. It causes various lock-ups, missing dongles or even dongles missing licenses. I tried with a mix of using the dock + machine ports, machine + machine ports, dock + dock ports, USB hubs, etc.

It is all fine in Mojave. USB sharing in Parallels Catalina is struggling though. Anybody tried VMWare Fusion?

1 Like

Someone at Pace told me that they use Virtual Box. I gave it a try but it didn’t work either (and was a WAY worse experience in general).

All things point to Catalina…


1 Like

Yes, I’m running VMWare 11.5 on a Mojave host system.

A Windows 10 VM connects with an iLok fine.

A Catalina VM does not connect with an iLok. I filed a support ticket with PACE about it, they eventually got back to me that PACE “do not formally support the use of VM’s”.

I just saw the hint above in another reply to give it “full disk access” in macOS security… haven’t tried that yet, but I’ll see if that helps.

1 Like

PACE “do not formally support the use of VM’s”.


any updates on this? is it really messing up my build pipeline.
Usually I would use VirtualBox for windows builds but the ILok just won’t be accepted when I try to sign my plugins. It just worked randomly once or twice after multiple times reconnecting the ILok. I really have no idea whats the reason behind.

Has anybody found a solution by now?

I just installed the new Parallels 16 and unfortunately, the problem still exists. Damn.

I just switched from VirtualBox to Parallels and it seems to work for me. At least in the first few attempts the VM always accepted the iLok and the plugins got signed.

Parallels Version 1.5.0 (20116)
VM: Win10
Host: Catalina 10.15.6

I find one iLok works fine reliably. Having 2 iLok attached usually turns up problems for both the host and virtual OS. I had some better experience in VMWare, but have not tested that fully.

I use VMWare Fusion with VirtualHere for USB sharing. It works without issues. You need the VirtualHereServer on your Mac and the client on your windows VM.

Followup, with good news:

The Catalina VM I mentioned before (running in VMWare Fusion) is now connecting fine with the iLok.

The trick was in Fusion’s Virtual Machine Settings window, to open the USB & Bluetooth pane, and downgrade “USB Compatibility” from 3.1 to 2.0. This was mentioned above in a post in this thread, so thank you for the idea.

Full setup details for those who are troubleshooting:

Host system: macOS 10.14.6
VMware Fusion 11.5.6
VM OS: macOS 10.15.1

iLok is an iLok 2 (plastic casing)

PS: No changes to System Preferences > Security & Privacy > Full Disk Access were needed in this case.

1 Like