Ios icons not showing up


#1

small bug:

xcode 4.3.2
added two icons to introjucer (compiled today): 72x72 and 144x144 as we’re on ipad
rebuilt, but no sign of the icons on ios.
can’t see them in the build summary infoi (app icon) but my target (in xcode) does show the icon I used…

  • bram

#2

bump ! :slight_smile:

  • bram

#3

Those aren’t valid icon sizes for iOS:
http://en.wikipedia.org/wiki/Apple_Icon_Image_format


#4

Mmmm, yes they are:
http://developer.apple.com/library/ios/#documentation/userexperience/conceptual/mobilehig/IconsImages/IconsImages.html

Or:
http://developer.apple.com/library/ios/#documentation/iPhone/Conceptual/iPhoneOSProgrammingGuide/App-RelatedResources/App-RelatedResources.html#//apple_ref/doc/uid/TP40007072-CH6-SW1

You are referring to OSX icons, not iOS icons. Actually and interestingly, on osx (using exactly the same PNG’s in Introjucer) it works just fine - even though the icons are not the right size.

  • bram

#5

ah, I see… Well, I’m a bit stuck then - they must have changed the icon file format to allow these new sizes, but I can’t find any info about how to encode the entries for them… The file requires that each size has an OSType marker, and the only list of OSTypes I can find is on that wiki page, and doesn’t include those sizes. Haven’t time to reverse-engineer the format right now, I’m afraid, but if someone can point me at the format details, it’d probably be quite easy to update the code to use it.


#6

Maybe it’d be a good idea to move this thread to the OSX/iOS forum?
I have no idea where to even start looking for this, people with more iOS experience might have a better idea…

  • bram

#7

FYI I’ve updated the icon stuff now to handle 256, 512 and 1024 sizes. Adding 72 and 144 should just involve finding out what the OSTypes are for those sizes.


#8

Jules,

Would this just be a question of adding icons manually to the xcode project and reverse-engineering them?

  • bram

#9

Yeah, you’d have to dig around in the .icns file to see what numbers the Apple tools put in there.


#10

FWIW, I thought iOS didn’t use .icns files like OS-X. I thought it was just a matter of adding PNGs with specific names tot he bundle and providing the correct keys in the bundle .plist.

https://developer.apple.com/library/ios/#qa/qa1686/_index.html


#11

Oh, FFS Apple…

It does look like having an icns file is also supported, but this is obviously yet another completely different way of creating icons.


#12

Hey Jules,

I rebuilt the Introjucer yesterday and recreated my projects, but still no icons… Should I be doing something special or wasn’t this implemented yet?

I did see some icns file in the project, but when I deploy to our ipads (I tried iPad2 & iPad3), still no icons…

  • bram

#13

The icns file stuff works fine, but I haven’t looked at doing anything iOS-specific with PNGs


#14

Ah ok…
So no icons yet for iOS.

  • bram

#15

[quote=“bdejong”]Ah ok…
So no icons yet for iOS.[/quote]

Add them manually in your xcode project.

Bruce


#16

Recreating the project in the introjucer would wipe out those changes again, so I’d rather not…

Bram


#17

Bump .... how are people getting icons to work on iOS? I've followed the naming conventions and have the correct sizes, tried adding them via IJ, but no luck.


#18

Just add the icons to the project and make sure they are not added to the binary resources or compiled (so they get copied into the ipa bundle).

If you make sure they are named appropriately Xcode will pick them up and use them:

 


#19

Can confirm - this is what I figured out shortly after posting this.

Thanks.

Not sure the difference, but the names I used are more like:

Icon
Icon-Small
Icon-Small@2x

XCode incorrectly tells me there is no icon, but then when it builds, it is there.