Is JUCE_MODAL_LOOPS_PERMITTED #defined in the Projucer?

It seems that it is #defined in juce_PlatformDefs.h, but do you just manually set it in this file to 0 if that’s what you want? i don’t see it in the Projucer…

To disable modal loops from the Projucer, you can add JUCE_MODAL_LOOPS_PERMITTED=0 to your project’s Preprocessor Definitions field.

1 Like

Thanks!

On this topic: setting JUCE_MODAL_LOOPS_PERMITTED=0 broke my build this afternoon…

My project is generated with CMake, if it matters.

with JUCE_MODAL_LOOPS_PERMITTED=0, my build succeeded on MacOS with AppleClang and on Windows with MSVC, but failed on Ubuntu 18.04.5 with GCC 7.5.0 with this error:

Thanks for reporting, this has been fixed on develop.

yay, all three OS’s builds succeed now! Thanks!