Issues with the new JUCE 5 Projucer


#1

I have seen too many new topics about the JUCE 5 Projucer ! Maybe it could be the time to create one and put all the issues people would like to report in the same place :slight_smile: So I start here ! (because my question can’t be put in another topic without being off topic it seems).

First congratulations with the new UI of the Projucer, it seems really solid and pleasing to use. My only complaint now would be the need to compile two versions of it if I want to use it without an internet connection available (one to log my pro license, and one in GPL for offline use) but I can manage that.

So here is my first issue report. When I try to log in without an internet access, I got a message telling me the need to compile if necessary the Projucer in GPL mode. There, I can click on “try again”. I did so after reactivating my internet connection. But then, the Projucer told me it wasn’t able to find my license anymore on my account. However, I just closed that window and then the Projucer was working, with my license displayed in the top right of the window.


#2

So would you mind collect the other ones and link here? That way you draw the attention into this thread.

OT: Also this brings back the topic of a missing bug tracker (the github is not really used, is it?) And also the lack of transparency, together with the unknown how the premium support will be implemented?

If the juce team could go into closure and come up with a model people can understand? The communication and transparency about what’s happening next / what is on the radar is really needed.
Otherwise you waste time reading and answering the same bug report over and over.


#3

I don’t know if its just me but I struggle to see highlights on the dark background in the new projucer?

It’s visible on the other colour schemes but I prefer the dark for less eye strain.


#4

Yes, the github tracker is being used (we’ve been closing dozens of issues these past few days). However, if you do open an issue then please also post about it in the forum. This often useful to discuss possible solutions and get other users feedback.


#5

I think it would be a good idea to start keeping the two separated: bugs should be discussed on the issue tracker, while the forum is left for everything else (mainly, questions from users, which only in a small fraction of cases lead to bug reports).

This certainly requires some active moderation on the forum: once a bug is opened in the issue tracker, topics pertaining it should be “closed” and notified that the discussion continues there, to avoid duplicates and to give a better overall picture of what is still open, what is being worked on, what may require attention from us other developers, etc.


#6

New issue report

  • In the Projucer (windows 8.1), when you create a new project and select the location of the file, there is a label in the bottom left which should display “folder”, I have “fold…” instead
  • Again with the Projucer, I can’t make the live coding engine with WIndows 8.1, I always have missing “memory”, “excpt.h” or “windows.h” files whatever the SDK I want to use (any of th Windows 10 or the Windows 8.1). I’m using VS 2015, I should have everything available right since I don’t have any problem of compilation when I use VS ?

I made it work by including extra headers and choosing the 8.1 SDK :

C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\include
C:\Program Files (x86)\Windows Kits\10\Include\10.0.10240.0\ucrt
  • During execution of the Projucer live coding engine still on Windows 8.1, I can’t click on any of the popup items, like the one appearing when I click on the set size button
  • On Mac OS X, I did the design of a UI with the GUI editor, and when I want to see the result using the live engine coding, a default look and feel is used instead of what is defined, so the appearance and colours of my controls are wrong

Thanks in advance @fabian and the JUCE team !


#7

New one, in the Projucer when I want to add a new folder (group) in the hierarchy of files, I can see the label behind the TextEditor allowing me to enter the new name of the group. I see the N of “new group” at the left of the TextEditor…


#8

same problem here with projucer 5.0.1 on windows 10&VS17.

when going to “component” drop down menu and clicking any component, for example MainContentComponent, and then selecting either “zoom” or “set size”, then clicking any of the options from the pop up menu does nothing. only button that does anything at all is “flip orientation”.

it would also be really useful to have the window open instantly when clicking the component name in component drop down rather than having to click the projucer icon on the bottom of the windows screen and then selecting the component view to open on screen.

also experiencing random “projucer has stopped working” crashes when switching between the component views as described above.

all this happening with a fresh GUI project with one rectangle and text object added on a new GUI component just to test how the VS17 exporter works.

already spend ages trying to get projucer 5.0.0 to work, now experiencing this on 5.0.1. some up to date how to set things up tutorials or FAQ for each platform would be really useful.

you know, which sdk versions to use, where they must be installed and which system header header paths to include in projucer etc. etc…


#9

The same here with Projucer 5.0.1 and VS2015.

With VS2017 the live engine does not work at all (errors about missing Windows SDK header files) probably because VS2017 is installed on D. Providing links for Projucer (‘system header files’ field) does not help either, but please note it worked with VS2015 also installed on D (after providing the mentioned links).

To be sure everything is right, I uninstalled VS2015 leaving VS2017 only but nothing changed. It is not a big issue because all projects generated by Projucer compile and work perfectly in VS2017 and VS2015, but it would be nice to have this live feature working.


#10

New one, if I add a file in a Projucer project, which is not in a given group, I can’t find a way to tell if I want to compile or not, include it in the binary data or not, without putting it first in a group, changing the properties, and then putting it outside the groups again.


#11

This is fixed on develop now EDIT: forgot to say how - if you right click on a file in the tree that’s not in a group it’ll have these options in the popup menu


#12

VS17 Community/WIN10/Projucer 5.0.1: After renaming a source file on File Explorer “Source” drop down menu and then pressing “Save and open in IDE” results in source file being renamed ok, but the class/function names etc. in the actual code wont get renamed. Only thing getting renamed is the the include statement. “Clean All” or “Build Now” from build menu does not help.

Example: renaming source file “left_pane.h” to “leftPanel.h”:

Renamed the file and clicked OK to the “Do you also want to rename corresponding “left_pane.cpp” file to match?” dialogue window.

The actual file name changes to leftPanel.h and so does leftPanel.cpp.

In leftPanel.cpp the #include <leftPanel.h shows correctly but everything else in leftPanel.cpp is unchanged like left_pane::left_pane(), left_pane::~left_pane(), left_pane::paint(), left_pane::resized()…

Is this intented behaviour, I would expect renaming to change everything or nothing in the code, not just the include statement leaving everything else as is?

Of course I can rename in Visual Studio, but there seems to be lots of buggy things like this related to the exporter. And all the issues show up with really simple freshly started test projects.


#13

This is the expected behaviour - we can’t assume there’s a coupling between the file name and the names of any classes inside the file! There are loads of projects where this isn’t the case.


#14

Some IDEs allow you to use a refactor->rename tool to change class names like this, or you can just use plain old find-and-replace but it’s certainly not something we’d want to do in the Projucer when you change a file name.

What other buggy issues are you facing with the VS exporter?


#15

ok thanks, makes sense.

other issues were related to the crashes when switching between component view windows as described in my post earlier in this same thread.

also “JIT process stopped responding” related ones and some related to system/user header paths.

all these we’re happening with fresh GUI projects generated by projucer, just one or two gui components added. i’ll let you know if they happen again or are reproducable.


#16

One way to reproduce “projucer has stopped working” is to open up any example from the examples folder , select “Enable Compilation” from the Build menu, then launch the application also from the Build menu.

Then closing the application window by using the X on the top right corner of the window crashes every time + “JIT process stopped responding”. (Either the full size window or the small selectable window that pops up when mousing over the Projucer logo on WIN10 bottom screen tool bar)

All the example projects I tried behave the same and actually fresh GUI project templates too. So this happens every time I close the window.

Tried all of the available Windows target platform settings.

Does this happen on other computers with WIN10/Projucer 5.0.1/VS17 Community or is something wrong on mine or did I grab my copy of Projucer at a buggy time?


#17

Related “Visual Studio Just-In-Time Debugger” error message:

“An unhandled win32 exception occurred in Projucer.exe [2576]”

The value in the brackets varies.

I am running Projucer from C: desktop on WIN10 64bit.

(Projucer 5.0.1 Build date 5 May 2017).


#18

I get these same build errors…

…on Windows 10 with Visual Studio Community 2017 Preview and I’m using Projucer 5.0.1. There’s an issue on github here:

https://github.com/WeAreROLI/JUCE/issues/185

But it’s closed and it says that the issue is fixed in version 5.0.1. Strange.


#19

I pulled the latest master from GIT and compiled it but still suffering from this. There are also random crashes very often when switching between windows. Stopping the application from Build menu works ok.

Theres all kinds of random behaviour and sometimes lack of any action when doing changes to the code.

Also, when clicking the compile error messages in the “Errors” view, many times the Projucer does not take the cursor to the line of code where the error is.


#20

What is the intended purpose of “Play button” on each component listed in the Components menu???

Ok, the component window opens but none of Zoom, Set Size, Reinstantiate or View Code buttons do anything. Flip orientation works but that’s about it. The component can also be resized by dragging but it does not affect anything in the code or when running the application.