Projucer Windows7 compatibility error


#1

I just came across Juce for the first time, so I downloaded the package from the website. And I tried to open Projucer.exe. But I end with the following error:

Am I doing something wrong?

I would be grateful if anyone can provide some advice/guidance with the issue


#2

Well, that message seems pretty self-explanatory, doesn’t it? I think the precompiled binary is just a 64-bit version. If you need to run the projucer on older versions of Windows you can do that, but it just means you’d need to compile it yourself from the project in the GIT repo


#3

hey @jules :slight_smile:

First of all, Thanks for the library. I very much appreciate your hardwork.
yeah I’m on 32bit computer and that makes sense, ok - I’m downloading the repo from github … Can i compile it with GCC?


#4

You should get the proper tools:

Visual Studio (2012+ recommended) or xCode


#5

I dont have VS atm :frowning:

Are there any other alternatives?


#6

hey @carlosbarbosa Do you have a compiled version for 32bit?
I dont have right tools for compiling the source code


#7

If you don’t have the tools to compile the projucer, how are you planning on compiling your actual code?

VS2015 is free, there’s no reason not to get it.


#8

I have Code::Blocks, will that work?

What is the procedure for compiling the code, there are no instructions for compiling in the source code repo which i downloaded from github


#9

yeah VS2015 is free, already I tried to install it :wink:
but I came across an error while installation, for that I have to upgrade my OS, and I’m not comfortable with the upgraded versions. My current development environment is enough for my actual work(no offense)


#10

i have a 32 bits virtual machine i use for building RTAS, its Windows XP, Visual Studio 2010 with some service pack, thats the least i can recommend or you will suffer unneded amounts of pain.


#11

My machine is pretty old …

not sure whether it is sufficient for Juce development


#12

3 gb ram is not old… 512 mb is old

Get somehow VS2010 that will work


#13

Thank you Carlos, appreciate your help

Have a nice day! :slight_smile:


#14

Hello! I get same problem… I use Win32 x86 system. And I install VS2013.
Now I clone git repo and choose File - New - Open - Project from existing Code
Then I select

  • Visual C++,
  • Then I locate the folder (file unarchived from github project to separate folder).

And what I need choose then to recompile Projucer to Win32 ?
Once I select support ATL, MFC… But after Build command on project root I get many errors… And without this option I have the same errors…

  • Error 35 error C1083: Cannot open include file: ‘juce_gui_extra/juce_gui_extra.h’: No such file or directory d:\downloads\soft\visual studio 2013\juce-master\modules\juce_video\juce_video.h 58 1 jc
  • Error 36 error C2653: ‘CameraDevice’ : is not a class or namespace name D:\Downloads\soft\Visual Studio 2013\JUCE-master\modules\juce_video\capture\juce_CameraDevice.cpp 37 1 jc

And others…

Can you describe How to compile Projucer for x86 Win32 platform from your github project??
I select this… https://github.com/WeAreROLI/JUCE


#15

In order to build Projucer, you should open extras\Projucer\Builds\VisualStudio2013\Projucer.sln in Visual Studio 2013.


#16

After open the project Projucer.sln I have many errors, and then I change Build Platform from x64 to Win32. After that steps I click right mouse button, then select Clean and Rebuild.
There are many errors and cant Build…

Can you explain in more detail how to recompile a project under a 32-bit system, without rushing each time with one sentence?

Or to send a ready executable file for 32-bit?

I understand that you are all smart programmers and your framework is very cool, but why do ordinary developers have to experience difficulties working on 32-bit systems? Do you think that 32-bit is an old thing? I can assure you that I will develop the VST plug-in on a 32-bit system, since my Creative E-MU 1616 card does not support 64 bits, and the drivers are laggs. And also this company broke up or what happened there with it.
In general, they do not release new fixed releases of drivers, and I do not want to buy a new card
In short, explain please how to work on a 32-bit system, and can I then use your Juce framework without Weird magic?


#17

I am sorry, I shouldn’t have replied in only one sentence and assumed that what I proposed would work for you automatically.

Here are the steps I followed to build Projucer in 32-bit:

  1. Open extras\Projucer\Builds\VisualStudio2013\Projucer.sln

  2. Open the Configuration Manager dialog
    image

  3. Add a new platform to the solution
    image

  4. Select Win32 as the new platform
    image

  5. Close the Configuration Manager

  6. At that point the configuration is Debug Win32
    image

  7. Build
    image

I get 55 identical warnings (warning C4512: 'juce::ScopedTimeMeasurement' : assignment operator could not be generated), but it does compile.

I am using this exact version of Visual Studio 2013:

I hope this helps you.


Building Projucer for 32 bit?
#18

I do this steps, as I said at my last message. And you just copy my steps.
And I repeat again your steps… And get the tons of errors!
For example, at syntax check before build:
1 IntelliSense: identifier “String” is undefined d:\Downloads\soft\Visual Studio 2013\JUCE-master\extras\Projucer\Source\Project\jucer_ProjectType.h 39 11 Projucer_App
3 IntelliSense: Array is not a template d:\Downloads\soft\Visual Studio 2013\JUCE-master\extras\Projucer\Source\Project\jucer_ProjectType.h 43 12 Projucer_App
9 IntelliSense: explicit type is missing (‘int’ assumed) d:\Downloads\soft\Visual Studio 2013\JUCE-master\extras\Projucer\Source\Project\jucer_ProjectType.h 108 5 Projucer_App

and many others errors…
What is scary program code?
const String&
This is not C++ notation.
See this picture again…


#19

Having IntelliSense errors doesn’t mean that the code won’t compile. Sometimes Visual Studio doesn’t know where to look for a certain type or function (like the String and the Array types in your screenshot). While compiling, Visual Studio will update its database and resolve the IntelliSense errors.

Please check that you are using the Update 5 of Visual Studio 2013. In the second screenshot you posted, I noticed that you had 8 notifications, which usually indicates that Visual Studio is not up-to-date.
image


#20

I downloaded the ISO of Windows 7 Professional 32-bit and I installed it in a VM.

Then I let Windows download and install all the updates, I installed Visual Studio 2013 Community (Update 4), I installed git, I cloned the JUCE repository in C:\Downloads\sof\Visual Studio 2013\JUCE-master (as similar as possible to how you did it), and I built Projucer for Win32 successfully:

Maybe there is something “bad” in your clone of the JUCE repository. You can clean it by running the following commands (after closing Visual Studio and any program that accesses files in the repository):

git reset --hard
git clean -xdf