Projucer won't start

I’m a senior software developer with a lot of experience in GUIs and audio. I thought I’d try out JUCE so downloaded Juce 6.07 for Windows.

I double-click Projucer.exe and get the error: “the version of this file is not compatible with the version of Windows you’re running. Check your computer’s system information to see whether you need and x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher.”

Same error for DemoRunner.exe.

OK. I have Windows 7 Pro SP1, 32-bit on my dev box. I have newer OS with 64 bit on the laptop but it’s usually booted as my Linux server.

I’ve checked the FAQ and no mention of OS or word size. Ditto, no mention on the download page.

OK, I see in the README:

  • Windows: Windows 8.1 and Visual Studio 2015 64-bit

Hmmm… should I just code this by hand? Maybe there’s another adapter layer I should look at?

On 32-bit you probably need to build it yourself (at least that what i did on my Raspberry Pi).

1 Like

OK, if that’s indeed possible, perhaps there’s someone who’s already done it and made it available?

it is probably a lot easier than you are thinking it might be. see the extras folder in this repository…but download the whole thing.

1 Like

That is what i was thinking at first, but since JUCE’s minimum system requirements is claimed to be “Windows 8.1 and Visual Studio 2015 64-bit” and since OP mentions his platform to be “Windows 7 Pro SP1 32-bit”, I suppose it is a bit more tricky.

It seems that Visual Studio 2015 is available on Windows 7. But is this still possible to use JUCE with that OS? I don’t have any Windows machine at home thus i can not help a lot!

Hmm. looks like building may be doable. Here’s an old discussion:

OK! I got a build and a running executable of Projucer on Windows 7 32-bit. I opened the director …\juce-6.0.7-windows\JUCE\extras\Projucer\Builds\VisualStudio2017 and opened Projucer.sln in Visual Studio 2017.

Then, right-click on Solution ‘Projucer’ and select Properties at bottom of menu.

Then, select Configuration on left menu, then “Configuration Manager…” on upper-right.

Then Platform–><New…>–>Win32 .

Then close everything and F5 will build it without error and it runs.

So now I’m confused, if it’s all compatable with 32-bit, why not just offer that as a download? It’s really surprising to see they got it working… then don’t distribute it…

Good to know that it worked easily for you. Note that AFAIK even if it works it is not officially supported/maintained/tested. IIRC build-by-yourself was the only way to get executables in the past. Now, only the mainstream targets are pre-built. As usual resources are limited in a project with a small team. And people in this forum are more concerned (feature request) with the new things (e.g. C++17/C++20) than supporting 32-bit Windows 7! :smile:

1 Like