JAPF Demo AU from Juce 1.46 on Mac OS 10.6 (Snow Leopard)


#1

Has anyone tried to build the demo AU project from an older version of Juce on the latest mac os? Any reason why this shouldn’t work? I’ve corrected the paths to the Core Audio files, but I haven’t picked through all the compile errors yet. Trying to decide if it would be more worthwhile to build against Juce 1.5 (would require lots of tweaks to my code)


#2

Those compile errors actually didn’t have anything to do with Juce. A heads up to anyone trying to build an AU on snow leopard: the newest CoreAudio files won’t compile against MacOS10.4u.sdk. If you need Tiger support use 10.5 as the base SDK and set the deployment target to 10.4