Juce 5.4.1 VSTHost Crash VST3


#1

Hello,
We are experiencing many crashes with the VST Host when loading VSTi, especially VST3.
We are willing to help you debug that.

Here is an example of Izotope BreakTweaker VST3 crashing after drag and drop from the code of the VST Host provided in Juce. (no modif)

Any idea what’s happening in there?



#2

Another crash when playing some fast notes with the mouse on the Synclavier Arturia (VST3)



#3

Could you be more specific? What were you dragging and where did you drop?


#4

Hello Tom,

Thanks for your answer.
Just opening the VST Host, right click in the middle of the windows, selectionning Izotope->BreakTweaker
(Or drag and drop of the breaktweaker.vst3 directly on the window.)
Then crashing with the first stack above.

The second stack is the same procedure (with Arturia Synclavier VST3) playing some fast notes on the keyboard of the VST3 directly with the mouse (by clicking) and it crashes.

Thanks


#5

Unfortunately I don’t have either of those plug-ins to test with.

Does it work with a previous version of JUCE?


#6

Hello,
You can try with the demo of breaktweaker.
https://www.izotope.com/en/products/create-and-design/breaktweaker.html

It crashed also in the 5.3.1 we were using before migrating to the 5.4.1.
We were hoping a fix in the new version :frowning:


#7

@t0m : hi tom, where you able to reproduce the crash?


#8

I’ve not tried yet.

Does it work in other JUCE-based hosts like Tracktion Waveform? JUCE’s plug-in host is more of an advanced example of what you can do with the framework, rather than a full DAW.


#9

Is it happening with a release build of the Host that is not under the debugger? if it isn’t then copy protection may be at play. Other than that it might be better for iZotope or Arturia to debug these issues as they can look at both the hosting and plugin source code to determine the problem. Before that though you could do as @t0m says above and check Waveform, and even other non-JUCE hosts, or go back some commits in JUCE and see if the problem goes away - if it does you might be able to figure out the exact commit causing the issue.


#10

@t0m : just tried, it crashes also Waveform
@Anthony_Nicholls : both release and debug


#11

OK. So I reproduced this, changed a lot of things, fixed it, but it now works even if I revert to a previous state and reinstall the plug-in, so it’s hard for me to know what did it.

Could you please try building using the very latest VST3 SDK from here https://www.steinberg.net/en/company/developers.html ? If you delete modules/juce_audio_processors/format_types/VST3_SDK and replace it with the VST_SDK/VST3_SDK directory in the download that will be the easiest way to test.


#12

@t0m : We already have the latest VST3 SDK and we don’t use the one in Juce :wink:


#13

I think it’s a bug in the plug-in, but there’s a workaround.


#14

@t0m : Many thanks, solves the issue :wink:
Do you have any idea for the second stack above?


#15

If you could find out if it used to happen in older versions of JUCE that would be very helpful. Then, if it does, we can isolate the commit that caused it. Otherwise I’m not sure what’s going on I’m afraid.


#16

Yes, I will investigate ! Thanks for your help.