JUCE 5.4.6 download files don't include the current changes

Our CI downloads the JUCE files from this link: https://d30pueezughrda.cloudfront.net/juce/juce-5.4.6-windows.zip
However the current version doesn’t include the changes from 5.4.5 to 5.4.6.
Example: getRawParameterValue from APVTS still returns a float pointer instead of an atomic pointer.

The file was fine a couple of days ago, when our pipeline did not fail

Also changelist is still at 5.4.5 so the files are definitely from release 5.4.5 instead of 5.4.6

I am actually not sure if this links is really created by JUCE so I might be wrong :wink:

The github releases page is likely to be more reliable: https://github.com/WeAreROLI/JUCE/releases

Yea, I am about to change our CI right now. Still strange that the exact same link worked a couple of days ago and now has the old content in it.

I have a question about that. I tried to do a git pull on the repo…after the 5.4.6 update, but git just said no updates. I ended up just recloning it, but I lost a few little of my own tweaks that way. Anyone know why my pull isn’t getting the latest updates? I haven’t even working off any branches or anything.

did you check the remote? Maybe it was accidentally pointing to your fork?

Doh. Thanks. I forgot that I forked it. I don’t plan to do a pull request ever, not sure why I bothered to do that…but anyway that’s it. thanks.

So I changed my CI, however for linux, even the github release files don’t include all the changes.
Example: juce_AudioDeviceManager.h line 395:

on juce-5.4.6-linux.zip:
void addAudioDeviceType (AudioIODeviceType* newDeviceType); (old)
on juce-5.4.6-osx.zip:
void addAudioDeviceType (std::unique_ptr<AudioIODeviceType> newDeviceType); (new)

Something wrong with JUCE’s CI?

I’ve just re-released 5.4.6, so everything should now be as expected.

Going forward downloading binaries directly from GitHub is the way to go. We expect to retire the CloudFront CDN at some point.

1 Like