JUCE on Ubuntu 14.04


#1

JUCE no longer builds on Ubuntu 14.04 since the Webkit requirement was upgraded to webkit2gtk-4.0

Any chance on going back to webkit2gtk-3.0 or having a define for people who need to support older OSes?


#2

Even if I disable Webbrowser component, it still won’t build


#3

I’ve noticed that webkit2gtk-3.0 is quite outdated and doesn’t support many html5 features - for example, it doesn’t support ROLI’s sign in page. This is why I upgraded to webkit2gtk-4.0.

If you don’t need the Webbrowser component then simply remove the juce_gui_extra module from your project. You can also build with the juce_gui_extra module and link with the --as-needed flag. If you are not using the webview, then webkit2gtk-4.0 will not be a dependancy of your binary. You will, however, still need webkit2gtk-4.0 during compilation when using the juce_gui_extra module.

Let me know if this works for you. If not, we can always add a flag to the Projucer (similarly to the Projucer’s libcurl flag) to explicitly disable webview support. But I think most people can simply remove the juce_gui_extra module.


#4

I’m not using the web browser, but I can’t remove juce_gui_extra because I’m using some of the other classes in the module. There is an option in pro jucer to disable compiling browser, but that doesn’t update linker settings. I’ll try --as-needed flag, and get back to you if that works.


#5

If the --as-needed flag works for you, then we should probably always add this on linux.


#6

Where does this --as-needed flag go?
It doesn’t seem to help if I add it to the “Extra linker flags” of the PJ.
If I add it to the compiler flags section make complains about an “unknown option”.


#7

Yes it’s an extra linker flag. It won’t help for the Projucer as the Projucer uses a WebBrowserComponent.