Juce VST3 Plugin dosn't know KeyPress::numberPad1

Hi all,

when I am testing my Audio Plugin as Standalone the Numpad Keys ( 1 to 6 ) are working as expected.

I implemented them as:

        if (key.getKeyCode() == KeyPress::numberPad1) mPadA.press(velocity);

        if (key.getKeyCode() == KeyPress::numberPad2) mPadB.press(velocity);

        if (key.getKeyCode() == KeyPress::numberPad3) mPadC.press(velocity);

        if (key.getKeyCode() == KeyPress::numberPad4) mPadD.press(velocity);

        if (key.getKeyCode() == KeyPress::numberPad5) mPadE.press(velocity);

        if (key.getKeyCode() == KeyPress::numberPad6) mPadF.press(velocity);

I also used:

        if (key.getKeyCode() == 65633) mPadA.press(velocity);

        if (key.getKeyCode() == 65634) mPadB.press(velocity);

        if (key.getKeyCode() == 65635) mPadC.press(velocity);

        if (key.getKeyCode() == 65636) mPadD.press(velocity);

        if (key.getKeyCode() == 65637) mPadE.press(velocity);

        if (key.getKeyCode() == 65638) mPadF.press(velocity);

Which worked also well in the Standalone Version. I used DBG(key.getKeyCode()); to read the Keycodes. But in the VST3 Plugin in Bitwig for Example the Numpad Keys seems to use the same Keycodes as the Numbers above the Letters Block on the Keyboard. I have no idea why the Standalone and the VST3 behave differently.

Thanks a lot!


Which OS are you testing this on? I know that Windows passes the char down for 1 the same as numpad 1 (I ran into something similar recently).

Hey Joël, yes exact it is Windows 10. Did you find a Solution ?

No, unfortunately. I hadn’t had time to drill down into it to see where/how things could have gone wrong (or if it’s just how it has to be!). I’m pretty much just tinkering on occasional side projects when using JUCE these days, so won’t have much time to debug.

Thanks Joël for the Answer.