JUCE7 Audio Plugin causes Studio One slow GUI response

On Windows 7,
After moving to JUCE7, opening an Audio Plugin under Studio One makes the entire GUI of the DAW run very slow. Closing the Plugin Editor and everything is back to normal.
Created a whole new plugin (Basic) from scratch and issue still happens, while it does not happen with JUCE 6.x.x
(did not test on a different OS or DAW yet)

Noticed that there were changes in graphics regarding
But could not find how it is related to the plugin or how to work around it,
Any clue?

1 Like

This is happening to me as well, any updates on this? I’ll try and investigate myself but those graphics calls look like a good clue.

On my machine I’ve tracked it down to 04e7014d0f2f36790d9b904534633e362acde63e


Looks like the screen refresh rate sync is bugging out specifically on studio one… if you can’t find the bug easily is there any way we could disable this with a flag?

Have you tried the develop branch?

1 Like

Hadn’t seen this either!

If you run into a problem, particularly one that seems like it has a significant impact, then testing against the develop branch is a sensible way forward.


i always work on develop, just didn’t realise this commit had happened so haven’t been testing this particular issue.

Ok same here, glad it’s fixed - thanks for the update.

Thanks guys,
Another interesting update, not under Studio One as a plugin, I created an application (with JUCE 7.0.2) that plays videos using libVLC and the issue of slow frames is there also.

Did you find a solution for the UI problem with JUCE7? I have a user that reported similar problems on windows for all our plugins that using JUCE7: