JuceDemo stuttering on RaspberryPi3-64


#1

Just wondering if anyone would know of an obvious place to start to try to fix this. I have a minimal 64-bit Yocto image for the Raspberry Pi3 and I cross-built the JuceDemo for it. When I try to playback a file (or use the synth) in JuceDemo, I get the same result - stuttering, or chopped audio. Using aplay to playback the same file works perfectly. (Note, I had to set JUCE_WEB_BROWSER=0 when cross=building since the Yocto SDK did not have webkit, but I assume that has no bearing on the audio issue.)


#2

I’ve never used Yocto, so I’m guessing, try adjusting the buffer sample rate and sizes in the settings page? [start with the lowest frequency sample rate and biggest audio buffersize] if that works, increase the sample rate and/or reduce the buffer size and try again until you find the best (most sensible) combination that works.


#3

Did you build in release mode? The RaspPi is not powerful enough to do audio in debug mode.


#4

Thanks for the responses. I rebuilt in release mode, but saw no change in behavior. Sample rate didn’t seem to affect it either, but taking the buffer size to the max (6144) improved it, but did not completely get rid of the stutters.

I have a hard time believing that a quad core 1.2 GHz ARM is underpowered for just synthesizing a sine wave or playing back a stereo wave file. Like I mentioned, the aplay ALSA app works just fine. Thinking about it some more, I wonder if the fact that I’m using X11 forwarding in an ssh session could be affecting the audio? There is no X server on the actual Raspberry Pi 3 itself, so I am using ssh -X to connect and run the JuceDemo app.


#5

I’ve never really understood how to use it, nor what it tests/proves, but have you tried the AudioPerformanceTest app in the extras folder?


#6

I’m having the same problem! I’m trying to use the plugin host as an easy way of (surprise surprise) hosting plugins so i can use VSTs and software instruments without a laptop onstage. Did anyone ever find a solution to this?

Right now im just trying to use the Roli Sine wave synth. I brought my buffer size all the way up and my sample rate all the way down and i’m still having trouble.


#7

Also be sure to rebuild with neon support (-mfpu=neon or similar) otherwise most of the floating point operations will be terribly slow.


#8

If you are using the ethernet adapter (with ssh -X) while doing audio on the RPi3, you must disable turbo mode or you will get audio glitches:

smsc95xx.turbo_mode=N