Keyboard events trapped in SliderPropertyComponent


#1

hi,

I’ve defined

I’m using a PropertyPanel populated with SliderPropertyComponents but I can’t enter information into the edit box. All the mouse interaction is done perfectly (draggin, mousewheel, editbox selection…) but not the keyboard events.

here’s the CustomSliderPropertyComponent constructor code:

       slider->setTextBoxStyle(Slider::TextBoxRight,false,60,20); // text is *not* read-only
        slider->setSliderStyle(Slider::LinearHorizontal);
        slider->setTextValueSuffix(textValueSuffix);

any idea?

Do I need to register an extra keyboard listener?


#2

have you set in your plugin FilterInfo structure the editorRequiresKeyboardFocus to true ?
maybe is only that, i had a similar problem before…


#3

I thought that was the exact purpose of JucePlugin_EditorRequiresKeyboardFocus

I’ve made a search trough my projects, and i can’t find anything with editorRequiresKeyboardFocus or FilterInfo.

for info:
Juce 1.4
JAP 1.13
VSTSDK 2.4
tested in Live 5.


#4

Could be that live isn’t letting the keystrokes get through… Try it in a different host - I know that keystrokes work in tracktion, for example.


#5

Thanks, I’ll have a look tommorow.


#6

I have never had any success whatsoever getting my plugins to recieve keyboard events when running them in Live. I’ve tried lots of things, but I believe it requires a specific workaround to get the events. If the plugin causes the popup of a system dialog (e.g. a native file chooser) then that recieves keyboard events for typing etc., but i can never get a Juce Component to recieve them when as a plugin within Live.


#7

It’d be interesting to see if the key messages even make it to the WinProc, or whether Live is hooking them out before they reach our window.


#8

I’rve tested with Traktion and it works well, so this is really Live that is trapping keystrokes. I didn’t launch the debugger though to see if they really get to WinProc.


#9

Hope this isn’t a stupid question but – have you turned off Computer MIDI Keyboard in the Options menu?


#10

not stupid because I forgot to change it, but it doesn’t solve the problem.


#11

Is there any news about keyboard events in Live?
Does new JAP Framework solved the problem?

thanx


#12

I’ve not made any changes in the new version that would affect this…


#13