Keystroke problems with TextEditor


#1

Hey,
the TextEditor isn’t receiving keystrokes when it is used in plugins under windows in Samplitude, Live, Cubase…
This seems to be the same problem as discussed before:
http://www.rawmaterialsoftware.com/juceforum/viewtopic.php?t=4158
In the mentioned topic the same problem could be solved for Labels that where turned into a TextEditor by adding the complete Label to the desktop. In this way all hosts I tested that didn’t work correctly before, were able to receive keystrokes.
Unfortuantely this problem applies to the TextEditor Component, too. Since there is no “wrapping” Component like the Label that could be added to desktop, I’m looking for a solution to make the TextEditor work with the mentioned hosts and windows (on Mac the Editor seems to work properly).

Any idea how to do that?
Thanks


#2

I’ve seen this happen on mac too… anyway, the best workaround I could find was to subclass a custom TextEditor that simply moved itself to the desktop when getting the focus (always set it always on top when doing this) and then moved back into its original parent when the focus is lost (you should save its original bounds to re-set them properly when moving it back into the parent). Beware, this does work only for some hosts, while for others the standard texteditor works fine and this solution does not work at all, so you should check at run time which host you are running into, and decide according to that what TextEditor to use


#3

I think I have a similar problem. My plugin (AU & VST, Mac and PC) includes one editable combobox and one texteditor. Depending on the host (live, AULab, Logic…) I can’t edit the text.
I read different posts on this subject. It seems it is related to the setWantsKeyboardFocus method. I tried to play around with this method without any result. :cry:
Do you have clue ? I swapped to version 1.50 recently.