Latest JUCE / Projucer breaks AAX builds

const int32_t juceChunkType = JucePlugin_AAX_Chunk_Identifier;

/modules/JUCE/modules/juce_audio_plugin_client/AAX/juce_AAX_Wrapper.cpp:118:31: Expected expression

Did something change in the Projucer the way Extra Preprocessor Definitions are escaped?

Please can you provide:

  • The build system you’re using (CMake/Projucer)
  • The platform/exporter you are using (Xcode/VS/Other)
  • The value you’re using for JucePlugin_AAX_Chunk_Identifier

Are you definitely using the very latest version of JUCE? I just tried building the DSPModulePluginDemo, using the Projucer’s Xcode and VS2019 exporters. I added JucePlugin_AAX_Chunk_Identifier='blah' to the preprocessor definitions of both exporters. The builds completed successfully after that. Putting a message pragma in the AAX_Wrapper.cpp shows that the value set in the Projucer is definitely visible.

Ok, did the escaping format change recently? I have my quotes escaped.

There’s was this Xcode change:

I also made some escaping changes here, but I think these affect the project name and library paths:

I’m using latest Projucer on Mac I had to specify it as JucePlugin_AAX_Chunk_Identifier='\VSTC\' and on Windows as JucePlugin_AAX_Chunk_Identifier='VSTC'

Is that what you would expect?

When I tried this on Windows I didn’t need the escaping.