Logic 10.7.5 reporting wrong host?!?!

Hi there,

I just realised the latest version of Logic is giving me a wrong Host report ONLY in Native mode (Garageband), Rossetta works fine.

How can I fix this? I use isLogic() for some of the functionalities of one of my plugins when is loaded in Logic…

To reproduce, I created a callback and added the following code:

    juce::String isLogic = "NO";
    if (juce::PluginHostType().isLogic())
        isLogic = "YES";
    juce::String debugThis = "isLogic " + isLogic + " host " + juce::PluginHostType().getHostDescription();
    metresOutputTitle.setText(debugThis, juce::dontSendNotification);

When loaded in native mode, the reported text is:
Screenshot 2022-11-07 at 11.06.37 AM

When loaded in rosetta mode, the text as follows:
Screenshot 2022-11-07 at 11.01.06 AM

The wrong report happens both in Juce 6.1.6 and in Juce 7.0.2

On which JUCE commit are you? Do you get the same also on the latest commit on develop?

Juce 6.1.6

In that case I would guess that since then something has changed on Apple’s side (like maybe Logic no longer hosts plugins in-process) and that the fixed host detection is probably in JUCE for a while already.

1 Like

So I just tried compiling using JUCE 7.0.2 and still get the wrong host…

I had some problems with rosetta too a while back, this might be related.

I can confirm, as my version info dialog shows the reported host, and since 10.7.5 it really says “Apple Garageband”. With Rosetta, it still says “Apple Logic”. That’s odd! With 10.7.4 it was as expected.

1 Like

This appears to be caused by a bug (?) in Logic. The PluginHostType uses the host name returned from the kAudioUnitProperty_AUHostIdentifier property in the AU wrapper. In Logic 10.7.5, this name is “com.apple.garageband” instead of “com.apple.logic.pro”.


Sorry for that, that is indeed a bug in the latest Logic Pro version. We are looking into that right now.


Thank you! I lost so much time trying to find a bug in a plugin, that wasn’t even my bug :slight_smile:

It looks like the issue is still present in 10.7.6.

1 Like

Amazing… I completely gave up hope and simply added “if it’s logic or garage band”…

I saw people complaining on the internet that Apple turned Logic to GarageBand. I guess they really did?

10.7.6 was a highly targeted release to fix two very specific issues, so the fix did not make it into that release.

Just curious: why do you even need to know the host?

In general it may often be used to enable host-specific workarounds, for example see New Logic Pro 10.1 sample position bug


It’s funny that you mention that, since the ‘Host Report’ giving the wrong DAW name, to me, is a very important mistake that probably needs 20 seconds to be fixed :slight_smile:

But yeah, In my (short) experience, I’ve noticed developing for Logic is quite cumbersome and have had to apply workarounds… Can it be because I am a noob? Most probably, but it is what it is… :stuck_out_tongue:

1 Like

Still present in 10.7.7 too.


It seems that is was now fixed in Logic 10.7.8.


Yes, it slipped through the 10.7.7 release. But 10.7.8 fixes it. If it is interesting: it was a side-effect of our changes for Logic Pro for iPad.