Mac OS Update Stopped Microphone Input Detection

After updating to macOS Mojave it seems that the AudioAppComponent doesn’t pick up my microphone input (I’m guessing its to do with permissions).

Tried on a university machine on a previous Mac OS and the same code worked fine.

Anyone know a workaround?

You need to rebuild Projucer from the develop branch, run it & load your project, check the Microphone access option to enabled, resave, then you should be good. I’ve had to do this on all the JUCE apps I work on since upgrading!

1 Like

Hi
I have the same issue. I think the stable/master release of Projucer should be updated with this fix.
Our apps are breaking when installed on Mojave. If the app was first run on an older OS it seems fine.
Since this is a critical issue (as far as I can tell) I think it should be fixed in the master branch.
We have stopped using the develop branch for good reasons.

1 Like

Hey,
I got the same problem :

  • I’m working on a Mojave VM, sound input shows activity in system’s preferences pane
  • My app is not detecting input (output is fine). It is the same for real macbook, some are working and some are not (couldn’t get the version of my users systems)
  • The Audio Recording and Audio settings example apps are not working either.
  • Tried with both JUCE’s master branch and develop branch, same behavior

Is there something to do to fix that on my end ?

You need to add the Mic access entitlement in the Projucer project.
Mojave blocks access by default.

If you have existing software that doesn’t have that entitlement set you can enable it in Settings -> Security and Privacy -> Privacy -> Microphone.

Ok thanks, I actually didn’t see the “Microphone Access” option in the XCode exporter options… my bad.

Thanks again !

1 Like

Yep, already corrected it. Thanks !

Hi guys,

I have the same problem as described in first post by fordc004
Even allowing access to the microphone as percyhole describes it, using JUCE from the developper branch, I still get no audio…

Any idea?

Thanks