Mac Plugin not available on Logic

Hello. I tried moving the VST and AU files to different folders. and it does not show up.

Tried editing the scheme to run Logic directly and nothing. Running the plugin manager within Logic and nothing.

The plugin runs fine on Reaper. M1-Monterey. Any advice is appreciated. Thank you.


I counted the same question 5 times in one week…

Make sure to build the correct architecture, not “My Mac” but “Any Mac”, see this post:

Apart from that if you built the first time run killall -9 AudioComponentRegistrar. This does the same to finding new plugins like restarting the Mac.

Good luck

Thank you Daniel.

Will try that out tonight.

By the way, I forgot to mention I tried the “killall -9 AudioComponentRegistrar” as well.


Hi Daniel

It does not work. Sorry.

When changing to Any Mac it is not possible to run Logic automatically to debug. It shows the following error:

A build only device cannot be used to run this target.

Editing the scheme and removing Logic, it can build for Any Mac, then moving the AU file to the different folders did not work either.

One detail is that the AU components I have end with the following extension “.component” but the one compiled by Xcode is “.appex”.

Any other suggestion is appreciated.