Make "-std=c++11" an optional Makefile flag


#1

As it is, the Introjucer forcibly generates a Makefile with the -std=c++11 flag enabled.

I’m trying to get a repository to play nice with TravisCI, but its GCC version is old (and I don’t feel like writing a script to make sure that the VM’s GCC is up to date)… So, I need better control over this flag - to disable it.

Below is a modified version of the Makefile generator that lets me not have this feature enabled.

https://github.com/jrlanglois/JUCE/commit/b4fac186bdd9a78aaf3f1db3942eef9b4d9b3b0b


#2

Thanks! I'll add something that allows you to do this soon. :)


#3

You can use -std=c++0x which is compatible with gcc4.6 which travis uses.


#4

Cool - will try that out for the meantime, by manually editing the Makefile.


#5

Say, falkTX, would you have an example JUCE based GitHub repository plugged into TravisCI?

I seem to be having technical difficulties wrangling the bloody system, trying to get it to compile my project!


#6

I don't use IntroJucer, I always do my own makefiles or create a project using cmake or premake.

How doesn't it work though?
IntroJucer generates raw makefiles that you can just "make -C /path/to/makefile/dir/".

 


#7

The problem I'm having isn't the step that calls make on my Makefile, it's every other step involved that TravisCI finds problematic... I can't describe the problem, because I know very, very little about setting this sort of thing up, let alone Linux (which the commits on that yml file certainly reflect).

Here's the file: https://github.com/jrlanglois/jrl_acc/blob/master/.travis.yml

My goal is to really do this once, and bring it up as feature request as part of the Introjucer. I can't stand manually configuring the same kind of stuff, over and over again.


#8

https://github.com/julianstorer/JUCE/commit/8045d89b3a49794d2e215aabd45f7c43ee04be88

Does that help you? :)


#9

Giving the new logic a read; makes sense to me! Cheers!


#10

Can we have a -std=c++0x option please?

Some users are still using Ubuntu 12.04, which has gcc4.6 with only c++0x and not c++11.
This happens to be the system Travis uses too, so for those developers -std=c++11 is not an option.

 


#11

Yes, I'll do this soon. :)