Mojave + xCode 10.1 newb problems


#1

Hey Friends,
Making my first steps with JUCE (literally) and nothing seems to work ;/ I’m following the basic tutorial Create a basic Audio/MIDI plugin, Part 1: Setting up and I have a linker problem with VST3, (AU and standalone do build) , tried using legacy VST - just for sport and it seems that JUCE is looking for header files that named differently than the one i have in my vst2.x folder… tried building the AudioPluginHost and I have the same linker problem (linker command failed with exit code 1 (use -v to see invocation))

after checking several threads here I suspect that the combination of latest OS with latest xCode version might be just a bad combo ? not compatible ? am I missing anything ? couldn’t google or find here anything related specifically to these problems and yet I have not written a single line of code yet :confused:

thanks in advance - first steps here :slight_smile:


#2

open projucer, make a GUI app, open it in xcode, and see if you can even compile and run something as simple as that.


#3

The VST2 code was removed from JUCE, and VST2 has been killed off by Steinberg. If you already had a VST2 license agreement before this year you can continue to make VST2, but that needed to be taken care of by October of last year.


#4

Thanks for the quick replay - I am able to build the GUI app, and AU plugin and standalone audio app but not the VST3. any suggestions ?


#5

Thanks for the info, makes a lot of sense, any tips how to get the vst3 to build ?


#6

The Projucer has also a setting called JUCE_VST3_CAN_REPLACE_VST2 (to be found in the module juce_audio_plugin_client), and for some reason, Projucer doesn’t let it be turned off (same for the analytics btw.)
But you can force it off by adding in the AppConfig.h:

// [BEGIN_USER_CODE_SECTION]

// (You can add your own code in this section, and the Projucer will not overwrite it)
#define JUCE_VST3_CAN_REPLACE_VST2 0
#define JUCE_REPORT_APP_USAGE 0

// [END_USER_CODE_SECTION]

That helped in my case anyway…


#7

Ok, after many tests and errors it seems that i caused the problem by downloading the VST3 sdk and changing the root directory in the projucer to the one I’ve download… after clearing the path to default / no directory I was able to build with no problems - and it seems like it works perfect now ! back on the horse …
thanks !


#8

Hi Dan,
I can’t find the AppConfig.h in the module juce_audio_plugin_client?


#9

AppConfig.h is generated by ProJucer whenever you save your project and open in IDE:

29%20PM