Some problems of building VST and AU


#1

Hi. My computer is Mac OX 10.10 with Xcode 6 and I already use the lastest JUCE. I followed every step to configure the AU and VST (http://feature-space.com/en/post161.html and http://www.redwoodaudio.net/Tutorials/juce_for_vst_development__intro2OSX.html ) but it seems like something wrong and I don't know the reason.

The first problem is that when I run JuceDemoPlugin whatever I uncheck VST and VST3 or not. It will show 

"/Users/user/Desktop/JUCE-master/modules/juce_audio_processors/format_types/juce_VST3Headers.h:80:11: 'base/source/baseiids.cpp' file not found". 

 

The second problem is different. I tried to build a new plugin and it shows that

"/Users/user/Desktop/JUCE-master/modules/juce_audio_processors/format_types/juce_VST3Headers.h:80:11: 'base/source/baseiids.cpp' file not found".

I guess maybe I didn't configure VST correctly. But for the tip "copy VST3 SDK folder to "~/SDKs/" (home folder, SDKs)", I am not sure where the /SDKs/ is and I tried to put them in Xcode6/Content/Developer/Platforms/MacOSX.platform/Developer/SDKs. But it doesn't work.

 

I referred to some former problems but I still couldn't deal with them so I post my problems and hope someone can give me solutions. Thank you very much.


#2

It just sounds like you don't actually have the VST3 SDK, or the path is wrong..?


#3

After installing VST3 SDK, the second problem disappears but the first problem still exists...And I run the new plugin project (I don't add anything on the code) and nothing happens. Is it normal? Will it display "hello world" on the screen?


#4

In your post above, you've posted the same error twice, so not sure what you mean by the "second" one..?

And when you say "run" it, you need to load it in a host of course, as a plugin does nothing on its own. If you just hit "run" in Xcode, it'll do nothing unless you set Xcode to actually launch a host exe.


#5

Sorry, I post it too hurry and didn't notice I pasted twice....I already solve the original second problem. It's my final issue... 

The JuceDemoPlugin's problem:"/Users/user/Desktop/JUCE-master/modules/juce_audio_processors/format_types/juce_VST3Headers.h:80:11: 'base/source/baseiids.cpp' file not found" still exists after I put VST3 SDK and vstsdk2.4 in  /User/User/SDKs/. 

 


#6

Finally, I solve my problems by following this website http://www.insaneinthemainframe.at/2014/09/22/compile-the-juce-audio-plugin-demo-on-mac-osx-xcode-6-0-1/. It has some specific configuration details I missed before. And also thanks for your help, Jules.


#7

If you’re running into this error while getting started with JUCE 4.3.0 make sure to save your project in Projucer after changing the SDK path… this took me a while to figure out :wink: