New to juce and Xcode, can't find my AU or VST builds, please help!

Hi all.

I’m new to the juce framework and also this community, but thank you all, it seems like a really good forum.

I’m currently following some tutorials on the juce framework, but I can’t for the life of me figure out how to actually build a prober VST/AU that i can use in my DAW (Ableton, Reaper ect.).
I’m using the newest juce (7.0.5) and Xcode (14.2) and I’m on a mac (12.6.3).

I’m checking my Plug-in folders, but it dosen’t seem like xcode is building anything. Iv’e set the export section in projucer as /Library/Audio/Plug-ins/Components/, which is also the folders used by my DAWS. I’ve seen some other threads around and tried their solutions, but none of them worked.

If anyone has any idea or a guide or some documentation, please help me!

Thank you for your time and effort, it really means a lot to me.


dont forget that macos has 2 locations for plugins:
there’s also a library folder in your userfolder, and that is where my plugins go when I compile

1 Like

Make sure that you’ve selected one of the plug-in targets in the drop-down selector at the top of the Xcode window (there’s a screenshot in the linked post). Select the VST, AU, or All target as appropriate. Avoid selecting the Shared Code target, as this will not build a complete plugin.


Hi. Thanks for your messages, very nice of you to take the time to help me out.

Thanks to the thread linked by reuk I’ve now successfully build something, but it won’t be registered as a plug-in in ableton, reaper or audacity, who just tells me it is broken. I’ve tried to rescan my plug-ins multiple times.
All I’m currently building is the standard juce Plug-in basic package to both AU and VST3.
I’ll keep on trying to figure out what’s wrong, but damn, I feel a bit dumb.

Cheers and thanks all.

For the AU to show up you need a magic spell or restart.
Here’s the incantation to put into the terminal:

killall -9 AudioComponentRegistrar

When you now start Logic or any host that can do AU, it should pick it up.
It doesn’t matter if it is in ~/Library/Audio/Plug-Ins/Components or /Library/Audio/Plug-Ins/Components.

Good luck

P.S. this is only necessary when a new plug-in was added. It is not needed after every build.

1 Like

Okay, thanks Daniel.

I’ve tried that command, but still no luck.

But good to know that it does to matter which directory the AU or VST’s are in.

I can find my AU’s, but non of my DAWs will find it. To be clear, I have multiple AU’s and VST’s in multiple DAWs, with exactly the same location, working just fine. So i’m thinking the issue must be in xcode or juce?

Cheers and thanks

To find that out, you can use the auval or auvaltool (the former calls the later).
You can either call auval -a to list all plugins that are found.
Ideally you check the help of the tool to get comfortable with it auval -h will give a lot of options.

auval -v aufx abcd Manu

would test the plugin with the code abcd from manufacturer Manu.

Note, if you used the same combination of plugin type (usually aufx), manufacturer (defaults to Manu) and subtype (a random 4 characters code) for more than one plugin, they will hide each other. So if you started from a copy of an existing plugin, there is a good chance that happened.

There are a few more undocumented restrictions, e.g. the manufacturer must contain at least one upper case, appl is their special case.

P.S. the manufacturer and subtype you specified in Projucer or in cmake when calling juce_add_plugin

1 Like


That was a lot of cool information thank you so much for taking the time!
Hope to get it to work today! Really looking forward to fixing this issue, so I can actually develop haha.