New DSP module will not build on Linux [Solved]


#1

Hi!

Nice job on the new dsp module, one little quirk:
The Makefile projucer creates set -std=c11, but the new dsp module requires -std=c14. Could you please update projucer to make a valid Makefile? :slight_smile:

All the best!


#2

Oh yeah, and just to be clear. I have read the announcement here: https://juce.com/releases/juce-5-1 where you state: “Projects that had a specific verison of the C++ language standard set for exporter build configurations will instead use the default (C++11) when re-saving with the new Projucer.” and tried that, which does not work :slight_smile:


#3

Alright, I was not looking in the right place. It works now, sorry!