Newly created Plugin won't load in Logic


#1

Using the tip I created an AU plugin where I left everything as default in IntroJucer except disabling VST. The plugin is found in Logic (10.2) but when I try to load it, I get an error message that it couldn’t be loaded and I should contact the developer or support.
Reaper on the other hand can load the AU.

I’m on OS X 10.10.5 and I built the plugin in XCode 6.3 using the 10.10 SDK.


#2

Have you run auval on it? Might give some more helpful info.


#3

I validated from within logic where it passes. The JuceDemoPlugin works in Logic. When comparing the auval output of both plugin I could find nothing suspicious.

On a closer look I noticed that the channel configuration is “[-1, -2]” instead of “[1, 1] [2, 2]” but this doesn’t seem to make a difference as the plugin also won’t load if I set a deprecated channel configuration accordingly. The configuration given in auval changes in that case, though.


#4

Same here :-(

What I did:

1) Grab the latest source from github; rebuild introjucer on XCode 7.0

2) Create a new audio plugin - using default settings, nothing changed other than settings paths.

3) Compile on XCode 7.0 / OSX El Capitan 10.11.2

4) AU validation runs without problem

5) Open in Logic Pro 10.2.0 -> Plugin crashes

Also existing projects now crash Logic Pro (keeping all local and project settings identical, just updating the juce repository makes existing projects that ran fine before now make Logic Pro crash)


#5

I've tested exactly that recently on my mac. Maybe I broke something last minute before pushing JUCE 4.1. Have you tried re-scanning the plug-ins in logic (via Logic's Plug-In Manager)? The slight difference in configuration ([-1,-2] vs. [1,1], [2,2]) may require re-scanning. 


#6

The plugin was newly created so there was no previous version with a different channel configuration if that’s what you mean.
I also rescanned in Logic’s Plug-in Manager several times to check whether it passes auval which it did but Logic still showed the error message when loading the plugin.


#7

Any luck in reproducing this issue? I also tried the same procedure while building for older deployment targets, unfortunately the resulting AU still won't work in Logic Pro X; re-scanning and running AUVAL gives a full 'PASS' on the newly created plugin.

Also XCode complains about a bunch of deprecated functions present in juce_mac_CoreAudio.cpp, in particular AudioHardwareServiceHasProperty, AudioHardwareServiceGetProperty, and AudioHardwareIsProperty being deprecated in OS X 10.11 but obviously being used in JUCE. Probably unrelated but wanted to share it anyway.

 

 


#8

To complicate things further - If the plugin is allowed to have up to 8 inputs and outputs (in any [nInputs,nOutputs] configuration, it actually does work in Logic Pro X.

Then, if I restrict the allowed channel configuration back to two inputs, two outputs by overriding setPreferredBusArrangement(), it keeps working even with a re-scan!??!

This may explain why, if you have tested this yourself, you do not experience the problem while others do - you may need to create a new project with a unique name / plugin ID in order to be able to reproduce the problem...?

 

 


#9

OK I think this is fixed now on the latest tip. Please remember to re-scan the plug-ins in Logic otherwise Logic will still complain. Please let me know if the fix works for you.


#10

Seems to work here too, thanks!


#11

Works here, too. Thanks for the fix.