Bloody AUs


#1

Ok, I shouldn’t have to ask this, but has anybody had this problem on 10.5…

Building my AUs is no problem, auval and aulab are happy with them, and they pass the auval test. But Logic 7 refuses to use them - in fact, it refuses to even open the files to test if they’re valid or not. I can’t find any difference whatsoever between my AUs and other ones that work fine, and am stumped. I suspect maybe some kind of embedded Mac file type field that is invisible in finder? Anyone had similar experiences? I’m sure I’ve been here before but have forgotten how I fixed it…


#2

questions :

Are you using the UB version of Logic 7
Are you using xcode 3 or xcode 2.5 ?
Have you opened the AU Manager in Logic 7, see what written ?


#3

Yes, it’s the UB version, I’m on XCode 3 now, and the damned AU manager doesn’t even bother listing my plugins! Not even to say they’re no good!

It clearly doesn’t even think they’re potential plugins, but all the other hosts are fine!


#4

try to move your plugins from system Components dir to user Components dir.


#5

nope, already tried both of those places. Logic is correctly loading other stuff from both of them.


#6

did you change this in the Core Audio SDK?


#7

Looks like the version I’m using is correct, according to that post.


#8

Have you tried Logic 8?


#9

No, haven’t got a copy of logic 8, but if V7 loads other plugins, it should load mine!


#10

Having same problem with AU’s here too. Also, still having that 32 Output channel AU issue.