No Title Bar on VST Window in Max 7

I’m loading my VST plugin (built with Juce 4.2.4) in Max 7.2.4 and no title bar is shown. I built and tested loading the JuceDemoPlugin in Max and the same thing happens - no title bar.

When I load either of them in Ableton Live there is a title bar. I’ve tested loading plugins from other developers into Max and they do have title bars.

As I understand it the window frame is provided by the host, not the plugin, so Juce must be blocking this in some way.

To replicate in Max

  • Create a new patcher window.
  • Create a vst~ object, right click on it and chose to and open its help window.
  • Enter edit mode in the help window.
  • Edit the “plug” button to be your equivalent of “plug /Users/chrisgr/Library/Audio/Plug-Ins/VST/JuceDemoPlugin.vst”. i.e. The path to the plugin.
  • Exit edit mode.
  • Press the above created button.
  • The plugin should load without error and this will be reported in the Max window.
  • Press the “open” button.
  • The window should open but there will be no title bar.

Which operating system is this? Seems to work fine in macOS sierra:

I’m on OS X El Capitan (10.11.6). I don’t want to upgrade to 10.12 immediately. I’d have thought that the Juce plug title bar would have been working on recent versions of OS X and Max.

Attached is an image of JuceDemoPlugin open in Max with a missing title bar.

When I’m able I’ll update to the very latest OS X and Max and see if the problem remains.

Sorry but I’m bumping this as I’m experiencing the same issue and haven’t found any related answers in the forum. I’m buildgin the Gain Plugin example, but when loading the plugin on a host running in El Capitan 10.11, I get the same behavior.

Is this related to carbon deprecation?

If you look at Fabian’s image – it’s using a Native Title bar… and in ChrisGR’s post’s image it appears that the contents of the GUI is too high by the Title Bar height… Make sure you’re using the latest JUCE SDK and try setting the title bar to native if your code is responsible for creating the host window (which is usually created by the host).


Thanks Rail_Jon_Rogut,

I’m not sure this is the problem. Like the original poster and Fabian have discussed, this only seems to be a problem in 32-bit hosts. I’m directly building the Gain Plugin PIP example and testing in Max 7 (32-bit). I’ve tested the plugin on 64-bit hosts, including Max 7 64-bit, and the title bar/window renders just fine. I’m also using the latest JUCE SDK.

Since I’m focused on writing a plugin, my understanding is that the host creates the plugin window right?. So I don’t think calling the method to set the window title bar to native will have any effect, unless I’m missing something.

I’m wondering if this is related to OSX 10.12 Sierra VST’s - Issues

Yeah, it sounds like a Max 7 32 bit bug.