Plugin (wrong font)


#1

Thats how the Juce-Demo plugin looks like with the latest tip in Logic Pro:

[attachment=0]jucegui.png[/attachment]

I also have the weird behavior that components with transparant-colour seems to cut out the window, and you can look through the window(?)

XCode 3.2.6


#2

Weird… Is that a music font? I’ve no idea how it could end up like that!


#3

not idea which font… I am the only one?
maybe this helps…

[attachment=0]debug1.png[/attachment]


#4

It must be something that the host is doing that’s mucking around with the graphics system - maybe there’s some kind of scaling setting? Can’t think of anything it could be though, I’m a bit stumped by that!


#5

The behavior is definitly new, didnt’t have the problem with juce-tips from the beginning of april.


#6

I can’t think of anything font-related that has changed since then. There’s some new CoreText stuff, but that was already there in april…


#7

could you (or someone else) reproduce the issue? Not sure which version i used in april (normally i update the juce source very often)


#8

will try tomorrow to find out since which tip i have this issue


#9

Thanks, it’d hopefully be simple to understand if we knew which commit caused it.


#10

Just a guess but…the refactoring of Font and Typeface to support named styles…


#11

If that is the case, then chkn you should try the last commit of April (9c21813960fb) which is one commit prior to when the font styles stuff was integrated for the first time. You should probably try the commit after that too.
However, by the look of your second screenshot, I’m not so sure that is the problem. The OSXTypeface looks right, it has a proper font name and font style, so the conversion from default font names to actual font names worked fine.

What version of OS X are you using?
Have you tried the plugin in other mac hosts? Do you see the same issue?


#12

yes sonic, this commit is causing the issue:

No, seems to be logic only issue (as far as i tested) - Logic Pro 9.1.7 32 & 64 bit - OS X 10.6.8


#13

Are you specifying an actual typeface name for the font? It might just be that you need to make sure that name is still correct now. E.g. you can’t ask for “Arial Regular” any more, because the “Regular” bit is now specified separately in the style name.


#14

I’m using the Audio-Plugin-Demo from the tip, changed nothing.


#15

That is very odd. Jules original theory may be correct. Logic Pro may be messing with the graphics context some how. You should try compiling the demo plugin with the CoreGraphics Renderer off to test this. This will tell you if it is a CoreGraphics issue.

I don’t own a copy of Logic Pro so there isn’t any way I can debug the problem. It would be interesting to know if this occurs with Logic Pro and OS X 10.7.

The only thing I can suggest is to step through the changes made to juce_mac_Fonts.mm since the beginning of may to try to isolate the actual lines that cause this issue:


#16

update - lasted change does not help (obviously it wasn’t designed to remove this issue)

[quote]The only thing I can suggest is to step through the changes made to juce_mac_Fonts.mm since the beginning of may to try to isolate the actual lines that cause this issue:
https://github.com/julianstorer/JUCE/co … c_Fonts.mm[/quote]
It was the inital commit from the first of may which caused the problems - nobody else with Logic who can confirm this issue?


#17

I think I’ve seen this though this wasn’t on my development system (still using 2.0.18) , so I can’t reproduce it atm.
This was with XCode 3.2.6, Logic (I assume 9) and a Juce tip from last week.

Chris


#18

Please try to compile the latest audio-plugin demo, just copy the latest tip in to a temp directory and hit build :slight_smile:

https://github.com/julianstorer/JUCE/zipball/f401d72b4b2563e622d079595276b1f56bcf2750


#19

I don’t have access to the machine it appeared on. I will try on my current system as soon as I’m on OS X again.

Chris


#20

Just tested with Logic 9.1.6 and a tip from this week, same font as in the first post’s screenshot.

Chris