prefersStatusBarHidden


#1

Hi Jules,

I had an issue with iOs 7 according to the Status Bar that would not hide.
I figured out that there is a new method to be implemented in  "JuceUIViewController" to control this bar:


- (BOOL)prefersStatusBarHidden { return YES; }

I fixed that problem by modifiing your code, but, could you implement it on a next version ? And maybe find a clever way to set it by avoiding touching your code.

This callback should return the state of fullscreen (ComponentPeer), what do you think?

I found my solution here: http://stackoverflow.com/questions/18525778/status-bar-still-showing

Thanks, 
Bastien


#2

You actually don't have to change the view controller. You can also add a key to your Info.plist file (you can add custom keys in the Introjucer for iOS Builds).

Set "UIViewControllerBasedStatusBarAppearance" to NO. If you use the PLIST editor in XCode the text says something like "View Controller based status bar appearance".

 

Good Luck,

-jjf


#3

Works perfectly! Cheers !


#4

I just wanted to add to this, the exact code I added in IntroJucer to get this to work was, under 'Custom PList' in the iOs configuration:

<plist>
  <dict>
<key>UIViewControllerBasedStatusBarAppearance</key>
    <false/>
  </dict>
</plist>

If that could be done a different way, please share, but this worked for me.


#5

For me, this didn't work. What did work in my case was adding this to the custom plist config in the IntroJucer:

<plist>
  <dict>
    <key>UIStatusBarHidden</key>
    <true/>
  </dict>
</plist>

Just mentioning in case someone encounters the same problem with that top statusbar still taking up space, even after doing setFullScreen(true).


#6

Well, forget the above: turns out there is a "Status bar hidden" checkbox in the iOS project configuration in The Introjucer, right above the custom PList text field... And that worked just fine for me ;-)