prepareToPlay (double, int) and prepareToPlay (int, double )


#1

Hi Jules, 

In AudioSource, prepareToPlay signature is : prepareToPlay (int samplesPerBlockExpected, double sampleRate)

In AudioProcessor, it is : prepareToPlay (double sampleRate, int estimatedSamplesPerBlock)

When you start having AudioSources and AudioProcessors in the same parts of the code, it can quickly become very confusing. Could we settle on one signature please ? 

 

 


#2

Yeah, I know. Unfortunately to change either one of these would be a pain for everyone who's overloaded the methods themselves. But yes, at some point they should probably both be changed to take a structure containing these values instead of raw parameters.