Problem with linking linux standalone GUI app

I just installed JUCE and am attempting to run the hello world project generated by PROJUCER using the makefile export. Everything complies fine but I get this error message when it attempts to link.

Linking FirstJucePlugin - App
/usr/bin/ld: build/intermediate/Debug/include_juce_graphics_f817e147.o: undefined reference to symbol ‘png_set_sBIT@@PNG16_0
//usr/lib/x86_64-linux-gnu/ error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
Makefile:92: recipe for target ‘build/FirstJucePlugin’ failed
make: *** [build/FirstJucePlugin] Error 1

How can I fix this?

Could it be possible, that you haven’t installed libpng?

No, it is already installed.

Give this a try:

sudo apt-get install clang freeglut3-dev g++ libasound2-dev libcurl4-openssl-dev libfreetype6-dev libjack-jackd2-dev libx11-dev libxcomposite-dev libxcursor-dev libxinerama-dev libxrandr-dev mesa-common-dev webkit2gtk-4.0 ladspa-sdk

Have you tried “make clean” and building again? I had lots of troubles with it giving me random errors until i deleted the previous built. Also had trouble with Linux libraries, even installing the same ones after installing and updating some others, making a clean install fixed it.
Another thing is: clang works wonders in a x86 Linux compiling JUCE stuff, but gives lots of troubles in my Raspberry (I have to use gcc there).