Projucer.app crashes in OSX 10.11.1


#1

Hi all,

 

Just downloaded Juce for MAC, and when I run Projucer I get the following error:

~/JUCE$ open -a Projucer.app
LSOpenURLsWithRole() failed for the application /Users/myname/JUCE/Projucer.app with error -10810.

I'm using a Macbook Pro with OSX 10.11.1.

Any advice? Thanks.

 


#2

That's a new one.

Could you please confirm the version of Xcode you have?

Also, does your username have a space in it?


#3

Thanks for answering.

XCode Version 7.1.1 (7B1005), and my username has not spaces.

 

 


#4

Thanks!

Couple more questions:

- Are you using tmux?

- Does this happen when you double click the app instead?

- Does this happen if you directly open the binary inside the .app folder?


#5

Ok solved! 

Apparently, the binary within the .app had not execution permission. So:

~/JUCE/Projucer.app/Contents/MacOS$ chmod +x Projucer

Thanks Joshua!

 


#6

I had the exact same! I updated from JUCE 4.1 to 4.2.1 and from the start I got the message “The Application ‘Projucer.app’ cannot be opened”

After, I found this post and did the same, changed the mode and made that file executable, and it all went fine.

Maybe the developers are aware? file a report?

Cheers!