Projucer build problem on macOS

I recently upgraded JUCE libs with a Git pull (April 12th 2020). I tried to upgrade the Projucer app in my /Applications folder (macOS), but didn’t find a built version in my JUCE folder (the one with the repo). I looked inside the build folder, but the file under extras/Projucer/Builds/MacOSX/build/Debug is just a symlink that points to my old in the /Applications folder, v5.4.4

So, I tried to build it with extras/Projucer/Builds/MacOSX/Projucer.xcodeproj

First I tried to use ‘Archive’, to get a Release build. I had to manually create that Release folder, because I didn’t have permission. Then I got linker errors

Undefined symbols for architecture x86_64:
  "PaintRoutinePanel::PaintRoutinePanel(JucerDocument&, PaintRoutine&, JucerDocumentEditor*)", referenced from:
      JucerDocumentEditor::updateTabs() in lto.o
  "typeinfo for PaintRoutinePanel", referenced from:
      JucerDocumentEditor::getCommandInfo(int, juce::ApplicationCommandInfo&) in lto.o
      JucerDocumentEditor::perform(juce::ApplicationCommandTarget::InvocationInfo const&) in lto.o
      JucerDocumentEditor::updateTabs() in lto.o
      JucerDocumentEditor::showGraphics(PaintRoutine*) in lto.o
      JucerDocumentEditor::refreshPropertiesPanel() const in lto.o

So, I tried to just click the Run button to get a debug build instead, because a debug build is really just fine for the purpose, but now I get a bunch of permission errors, clearly Xcode doesn’t have permission to alter directory structure in the extras/Projucer/Builds/MacOSX/ folder. I could simply give myself permission via the command line, but that makes me wonder: Am I supposed to be doing any of this at all? According to the documentation, a runnable Projucer app is supposed to be found in the JUCE folder, but I can’t find it.

Is it fine to continue with Projucer v5.4.4 for new products, or should I upgrade it?


I solved it by clicking the Projucer.jucer icon, clicking the Xcode button in the old Projucer, and build from there. While the problem is solved for me, I’m not sure whether to consider it solved for other users, as I don’t know what I would have done if I didn’t already have an old version of the Projucer. Maybe everything is working the way it was supposed to, I don’t know, I’m not the expert… :slight_smile: