Problems with Projucer at the tip?


#1

I just pulled the most recent version of Juce (in fact, I deleted the repo and re-cloned it) and I’m having problems with the Projucer. For starters, it wouldn’t let me open it until I re-enabled permissions in Projucer.app/Contents/MacOS/Projucer

Once I fixed that it opens. I tried to load a jucer file of mine and it hangs for about 2 minutes before opening. Once it opens, the paths to the modules are incorrect. This seems to be related to a change from directory name JUCE-OSX to JUCE. Once I change that back it finds the modules again. Now it’s hanging again because I clicked Save.

That stupid AuResources.r rez error is also back in my xcode project so that refuses to build, but I’m hoping that the answer lies somewhere in the many posts about that… This resurfaced after I tried to pull the tip of the JUCE repo. EDIT: This seems to have been related to the renaming of JUCE-OSX to JUCE.


#2

I ended up rolling back to 4.1, between this and the tragic loss of polymorphic targets I’ve had too much excitement for one night…


#3

Did you build the projucer your self? How can you have permission problems if you are building the projucer yourself?


#4

tried on 2 different new macs recently and worked ok for building it, maybe delete everything and try again?


#5

You bring up a good point and I think you have uncovered the root of my problem. I was just using Projucer.app as it appeared in my JUCE folder. I’ve had it there so long that I’d forgotten that it doesn’t appear there in the git tree and that you have to build it yourself. I think this led to me using an out of date, mismatched version. Perhaps when you download JUCE through the get-juce frontpage it contains an already built version? Anyways, that, and the associated directory name change, seemed to be the cause of all of these problems. Sorry for wasting your time.