Problem with building Projucer with XCode

with XCode 14.2 on a MacOs 12.6.3
i downloaded JUCE-master 7.0.5 from github, i ask XCode to build Projucer but it gives the following error that i don’t understand:

Do you have an idea why please?

I’ve never seen that before. It looks like there might be a broken symlink or something in the app bundle. Some things to try:

  • Go to Product → Clean Build Folder then try rebuilding.
  • If that doesn’t work, try deleting the entire repo and check it out again using git clone.

Thanks for your answer. I did : git clone , and in Xcode Product → Clean Build Folder and Build, but still get the same error.
Do i need to re-install Xcode or MacOS? or use Cmake?
(my purpose is to develop some plugins for MacOs or windows and initially i am working on linux)

Have you tried building any of the other example projects, e.g. the AudioPluginHost or the DemoRunner? Do those build correctly?

As I’ve never seen anything like this before, it’s difficult to say what the problem could be. Your versions of macOS and Xcode should be supported. Have you tried manually deleting extras/Projucer/Builds/MacOSX/build and then rebuilding?

Maybe it would be helpful to see the full error message.
Xcode has a view were you can find the output log.

It looks like a loop. It’s the same path concatenated over and over. Maybe some nested include problem?

Looks more like a cyclic link on the filesystem: just guessing, but inside the “” bundle, inside the “Contents/Resources” subdirectory there seems to be a link also named “” that links back to the bundle, with the effect that entering it e.g. for signing, will cause infinite recursion

Thanks for your replies and help. Since i am newbie with Macos (i use to work with linux) i just re-install (with power on, command-R) Macos, xcode, Juce and hope that in few hours, the fresh installation will work.

Hello, thanks.
Yes i have the same problem with AudioPluginHost: If i delete manually extras/Projucer/Builds/MacOSX/build and then rebuild, then the directory is rebuilded but the same error occurs.
Same problem with building DemoRunner.

Hello thanks for your reply. Here is the output log:

From that screenshot, it looks like the app is being copied into its own resources directory. That shouldn’t be happening in the first place (it certainly doesn’t when I build the project locally), so a good next step would be to find out why Xcode has added this copy step.

Have you modified or changed any settings in the Xcode project? Have you moved or copied any files in the JUCE repository?

For us to provide further help, I think it’s probably best if you:

  • Remove your copy of the JUCE repository from your system.
  • Set up JUCE again, but take detailed notes of each step you take, including full command-lines and every button you click.
  • Paste those notes here.

Hopefully, if the instructions are sufficiently detailed, we’ll be able to reproduce the problem and then debug it.

Thank you for your answer. Here is what i did. I have erased everything on the computer (a mac mini) and re-installed MacOs. But at the end i still have the same problem. Here is the details of what i did:

  • this is a mac mini, end of 2014, with MacOs 12.6.3
  • i install xcode from the App Store
  • on 2023/02/07 11:58 am, i installed JUCE 7.0.3 , using git clone
  • Using Finder, i clic on ~/JUCE/extras/Projucer/Builds/MacOSX/projucer.xcodeproj. This open xcode and make a “Processing files” working.
  • This gives a warning that asks me to “update to recommanded settings”. Photo 1. I clic on “perform changes” and “continue”. There is still a warning asking updating, i clic “perform changes” again but nothing is done (??). So this warning is always here. Photo 2.
  • On the left column, in directory Products, i select Projucer and on the right column that appears, i select Target Membership, Projucer- App and then in the menu, i call in the menu/Product/Build . This gives a message of error of Photo 3.
  • Is there a way to avoid Xcode? may be with cmake? does Juce produces cmake file “ready to use”, for a project (a plugin midi and/or audio project in my case)?

Thank you very much!

PS: the compilation of DemoRunner with cmake in a terminal works fine!

for reference, you can take screenshots on macOS more easily with the following keyboard shortcuts:

CMD+SHIFT+3: capture whole screen
CMD+SHIFT+4: caputre rectangular area / a window of your choice (you toggle between them pressing SPACE)
CMD+SHIFT+5: a little bar appears at the bottom of the screen allowing you to choose the capture mode

I think this is probably where your problem is coming from. Why are you changing the target membership? The “Projucer - App” target is already set to build “”.

Thanks! this is useful.

Thanks Reuk,
It works fine: by directly going to menu/Product/Build this bluids the Projucer and it works!
Thank you very much. (I discover Xcode, and my fault was that i clicked on a wrong button).

But now, i try to compile the example “GainPlugin”, the same way. At the ends i have the message “Build succeeded” from Xcode, but when i clic in Finder on ~/myJUCE/…/build/Debug/GainPlugin
i get the message (in french):
“Impossible d’ouvrir l’application “GainPlugin” car elle est peut être endommagée ou incomplète”.
That means
Unable to open “GainPlugin” application because it may be damaged or incomplete”.
I am sorry of my ignorance. This may be a simple problem, but i don’t find a simple solution with google search. Do you have an idea please?
(my first objective is to try your examples of midi and audio AU plugins from JUCE and test them with garageband)

Only .app bundles can be launched directly. For plugins (.vst3, .component etc.) you need to load them in a host application.

Also, at the top of the Xcode window, use the target drop-down menu next to “My Mac” to make sure that you’re building the “All” target. This will build all enabled plugin formats, including standalone.

Yes i would like to use first the standalone. Is it an app?
and sorry, i don’t see where to select “All targets” as you say please?

Use this menu from the top of the window:

Thanks very much! Now that i understand better, everything seems easier and to work fine.
Thanks a lot for your disponibility and for JUCE. Have a good day!