Error when building Projucer for JUCE framework on an older Mac

Hello everyone !

I’m currently experiencing an issue while trying to build the Projucer on an older Mac running macOS 10.15.7 (Catalina). I do not have Xcode installed, so I’m attempting to build Projucer using CMake and the command-line tools.

I have ensured that I’m using the latest version of xcode-select and I’ve tried building Projucer inside a build folder at the root of my JUCE folder with the master and develop branches, but I keep getting the same error message:

ld: file too small (length=0) file 
 for architecture x86_64

clang: error: linker command failed with exit code 1 (use -v to see invocation)

make[2]: *** [extras/Build/juceaide/juceaide_artefacts/Debug/juceaide] Error 1

make[1]: *** [extras/Build/juceaide/CMakeFiles/juceaide.dir/all] Error 2

make: *** [all] Error 2

Does someone already faced this issue ? I would greatly appreciate any suggestions or workarounds to help me build Projucer and start my project.

Thank you in advance for your assistance!

This is not a fix to the issue per se , but I was able to start using JUCE by downloading an old version of XCode and building Projucer with it. However, I’m still curious to know why it was not working with CMake