Projucer dark theme with black text?

Did something change from JUCE 5.4.7 to JUCE 6 in the themes? The majority of the text in the dark theme is… well… also dark for whatever reason. It was way easier to use before and honestly doesn’t make much sense why this would be changed. Is this a bug and I just need to reinstall?

That’s odd, it sounds like you have changed the preferences somehow. View->Editor Colour Scheme->Default (dark) will reset it.

I tried this, but it didn’t make any changes. It’s still all dark on dark. I’ve never touched the preferences before, which is really odd. All I did this morning was do the installation update to JUCE 6.

For me, the Dark theme looks right:

but the Light theme is not readable:

Try switching the colour scheme via the View->Colour Scheme menu from Dark to Light or Grey and back to Dark again. This should refresh everything. If it’s still not working after that you can try clearing the settings completely by deleting the Projucer folder in ~/Library/Application Support on macOS, C:\\Users\\username\\AppData\\Roaming on Windows, or ~/.config/ on Linux.

@ed95 I guess the issue comes from a simple confusion between “Colour Scheme” and “Editor Colour Scheme”. Why is it even possible to have “Colour Scheme - Dark” with “Editor Colour Scheme - Default (Light)”?
Also, why are the 2 provided editor colour schemes both called “Default”?