Projucer Text editor colors are changing (still looking for recipe)

I have a situation where the colors in the Projucer text editor are changing. Anecdotally I think it happens after I pull from my repository after the .jucer file has changed. But, I’ve not been able to manually choose steps that make it happen, so that may be a red herring. Mind you I don’t actually use the editor, but I thought I should report it. I am running Win7, and JUCE 5.1.1.

Correct colors:

Incorrect colors:

FOUND IT! Bringing up any of the dialogs from the File menu (About Projucer, Application Usage Data, or Global Search Paths) causes the text editor colors change. But, this doesn’t happen if I first bring up one of the dialogs from the Tools menu, and then open one of the dialogs from the File menu. So, the easiest recipe is launch Projucer and open one of the dialogs from the File menu.

I filed this as a bug on github.

Thanks for reporting, this is fixed on develop now.

1 Like

@ed95 I am still getting this behaviour (I was about to post as a separate thread but found this when searching the forum)

To reproduce.

  1. Ensure Projucer isn’t running at all and is not present in taskmanager
  2. Double click a .jucer file (assuming it’s associated with Projucer)

This brings up this weird and difficult to read colour scheme.

To not have this occur, I must launch Projucer from it’s own icon or a shortcut.

I hope this helps track things down to kill this once and for all :slight_smile:




Did you check whether the Projucer opening on double click is the same you open manually? You can check this using Windows task manager (Details tab, right-click and something like “Open Location”).
It might be that the linked projucer is an older version that doesn’t read the stored settings correctly.

Good suggestion @lkjb but unfortunately it’s not that. In both cases I’m pulling the same projucer.exe (compiled from the Dev branch).

Also I manually did a right mouse, and did a force “open with” and used the same path. Same result.

And finally in both cases, working colours and non-working, the Build info (JUCE v6.0.5, 8 Dec 2020) remains the same.

Still seems like this is a bug of some kind.

Exactly! I’ve got the same behavior.

1 Like

After some debugging the problem seems to be that when loading a .jucer file as command line parameter the colour scheme from CPlusPlusCodeTokeniser is used instead of the one that ProJucer has defined as dark or light colour scheme.

I tried a bit to find out at which point this goes wrong but as the colours are stroed within a settings ValueTrue which is being changed all over the place I wasn’t able to get far.


Nice detective work! :slight_smile:

Thanks for narrowing this down a bit, it’s now fixed on the develop branch:


Thanks very much for sorting this out, @ed95 Just to confirm this is working here just fine now :slight_smile: