Projucer Project broken after adding `.gitignore`

Hi all, I wanted to add a .gitignore file inside of Projucer to my Project to be able to see the .gitignore file inside of Visual Studio to be able to edit it… Which results in that visually nothing gots added. But now the Project seems to be defect as Visual Studio 2022 now doesn’t show the correct Structure of the files in the SharedCode Project:


I don’t know where all those fiels are comming from and also the Source fodler is missing. I also can see that some files are doubled.

Not sure how to fix that.

I also have hard times to work with Visual Studio 2022 and Projucer in general also the workflow between VS 22, Projucer and GIT integration in VS 22 is really bad and not handy.

To make it work currently I need to do those steps to be able to open a Project to work with:

  • Open the Project Eight.projucer which opens Projucer
  • Click on Save and open IDE to open Visual Studio
  • In VS22 then I need to retarged the Solution
  • To make GIT work I need to open the local Repository
  • In the Solution Explorer I send again need to open the Solutiion file
  • And then I have a working GIT environment and can Build the Project

Wonder if there is a better Solution for that.

It seems the Show all files was enabled. I tried before to disable it multiple times but it didn’t show any effect. Now it works.

You’re using the VS 2019 exporter in the Projucer. If you want to develop in VS2022, use the VS2022 exporter instead. I think this may allow you to avoid retargeting the solution.

Perfect reuk, used an older version of JUCE (6.1.1) and couldn’t find the VS 2022 Exporter. Installed latest JUCE (6.1.6) now which includes the VS 2022 exporter. Thanks a lot!

The new VS 2022 exporter also fixes the GIT Issues where I needed to reopen a local git repository.

Now I just save and open IDE ( VS 2022 ) inside of Projucer and everything is in place and works as expected.