Projucer / Xcode 7 suddenly resulted in the old au rez error


#1

Hi Juce Team, 

 

Seems really odd to me but I seem to be suddenly getting the old au rez error since having upgraded to Xcode 7. 

I'm using the Projucer on an indie license. I understand that the Core Audio/Audio Unit classes are now bundled/included in JUCE so I shouldn't be worrying about patching/setting up the audio unit files anymore. 

Any ideas why I might suddenly be getting this old error again ? Haven't seen it for some time and thought this was all solved. 

I can locate the Core Audio SDK and relevant files when navigating through my modules folder. 

 

Cheers 

 

Josh


#2

 

I also have the same error when I compile for a iOS project. It is a plugin and Is a Synth is selected. 


#3

What kind of plugin are you expected to get running on iOS..?

We are working on iOS AU support, but it's not released yet.


#4

Seems to resolve the issues if I copy all modules locally to the project....some sort of path issue. 


#5

I'm expected AU plugin to get running on iOS.

If JUCE doesn't support AU for iOS yet I think we shouldn't be able to add XCode (iOS) exporter in introjucer for a plugin project. 

Do you have an estimation for AU support for iOS?

 


#6

Hey team, 

 

Ignore this one. 

I moved my modules folder to a different directory and the paths are resolving....Xcode didn't seem to be able to resolve the path I've always used previously. Bizzare. 

 

Anyway not a JUCE issue. Cheers


#7

For iOS you'd need an AudioUnit 3 plug-in, which is something that JUCE doesn't support. We are working on it now. I can't promise any release dates here, since there are a few technical obstacles to overcome, but if all goes well we might have something in a couple weeks.


#8

Thank you for the answer and the estimation. It helps us to choose the right starting point for a new project.