Audio plugin compiling issues under Mac OSX 10.7.3


#1

Hello,

I have just updated my system to Mac OSX 10.7.3 and I’m using Xcode 4.3.2. For this I downloaded the latest tip of juce from git. I was able to successfully compile and run the Introjucer and from there I opened the Juce plugin demo to make sure things are working but I am running into a problem.

When trying to compile the Juce plugin demo I get the following error.

failed to find AUResources/AUResources.r
/Users/xtraction/juce/extras/audio plugin demo/Builds/MacOSX/…/…/…/…/modules/juce_audio_plugin_client/AU/juce_AU_Resources.r:50: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - SysError 0 during open of “AUResources.r”.
Fatal Error!
/Users/xtraction/juce/extras/audio plugin demo/Builds/MacOSX/…/…/…/…/modules/juce_audio_plugin_client/AU/juce_AU_Resources.r:50: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Fatal Error, can’t recover.
AUResources.r: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Since errors occurred, /Users/xtraction/Library/Developer/Xcode/DerivedData/JuceDemoPlugin-cohnhscbypqxjygfzalqsglfodlp/Build/Intermediates/JuceDemoPlugin.build/Debug/JuceDemoPlugin.build/ResourceManagerResources/Objects/juce_AU_Resources.rsrc’s resource fork was not written.
Command /Applications/Xcode.app/Contents/Developer/usr/bin/Rez failed with exit code 3

First, I tried just going back to the introjucer and disabled the AU build to only make a VST, since I saw a bunch of files missing in the AUWrapper folder. I looked for these files but there is no ‘Developer’ folder anymore where the SDK are in this version of OSX. I realized that the folder is inside the Xcode.app, in the Contents folder but i couldn’t find none of these files in there. But even like this I get the same error. I tried also a few things I found in the forum such as selecting 10.7 as my Mac OSX deployment target and did the same with the introjucer but still no luck.

Anyone had these issues before?? Could anyone please give me a hand to get onto the right path to be able to run the juice audio plugin, I would really appreciate it.
Thanks!


#2

http://www.rawmaterialsoftware.com/viewtopic.php?f=8&t=8682


#3

Yes! Sorry for the duplicated post was just about to post that link here myself…