Audio Plugin Demo Build Failing , Unable to find AUResources/AuResources.r


#1

Hi Guys, 

 

I'm new to the world of audio programming and am just beginning to experiement with a few things. 

I've been looking around for the right API's and Frameworks for me and have played around with the likes of RT Audio and QT but have now discovered the mighty JUCE and am looking to use JUCE as the environment for me to start learning and developing plugins. 

 

HOWEVER. 

 

I have run into a newbie issue. 

I am unable to build the Audio Plugin Demo in Xcode. The other demo projects seem to build just fine but im recieving the following error for the audio plugin demo:

 

failed to find AUResources/AUResources.r

/Users/joshuamarler/JUCE-master/modules/juce_audio_plugin_client/AU/juce_AU_Resources.r:49: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - SysError 0 during open of "AUResources.r".

Fatal Error!

/Users/joshuamarler/JUCE-master/modules/juce_audio_plugin_client/AU/juce_AU_Resources.r:49: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Fatal Error, can't recover.

AUResources.r: ### /Applications/Xcode.app/Contents/Developer/usr/bin/Rez - Since errors occurred, /Users/joshuamarler/Library/Developer/Xcode/DerivedData/JuceDemoPlugin-bfzxhcbnzygncreprdnhncbydwkj/Build/Intermediates/JuceDemoPlugin.build/Debug/JuceDemoPlugin.build/ResourceManagerResources/Objects/juce_AU_Resources.rsrc's resource fork was not written.

Command /Applications/Xcode.app/Contents/Developer/usr/bin/Rez failed with exit code 3

 

The juce_AU_Resources.r appears to be held in the correct place. One thing I noted was when opening the file in Xcode the entire file appear to be commented out ? 

I have attached the file as it currently appears in a .txt format with this post. 

 

If anyone could shed some light on this issue it would be massivley appreciated. Hopefully someone can help me out and I'll finally be able to get stuck in with JUCE!


#2

http://www.juce.com/forum/topic/aus-xcode


#3

Did you figure out how to get this working? In the thread jules posted the links are broken, and I couldn't find any good info.


#4

This problem should no longer happen since we embedded all the Apple AudioUnit code into the juce tree a few months ago. Are you using the latest version?