Xcode 4.3 plugin build error


#1

Does anybody know what I should do to make this build error go away?
I used introjucer(modularized) to create a plugin project then tried to build with xcode 4.3
As far as I can tell my system doesn’t have an AUResources.r file - what’s up with that?
I’ve been poking around the web all day, haven’t found a solution yet.

failed to find AUResources/AUResources.r /Users/kurt6string/Documents/jucy/v2/StageMidi/Builds/MacOSX/../../../juce/modules/juce_audio_plugin_client/AU/juce_AU_Resources.r:50: ### /Applications/Dev/Xcode.app/Contents/Developer/usr/bin/Rez - SysError 0 during open of "AUResources.r". Fatal Error! /Users/kurt6string/Documents/jucy/v2/StageMidi/Builds/MacOSX/../../../juce/modules/juce_audio_plugin_client/AU/juce_AU_Resources.r:50: ### /Applications/Dev/Xcode.app/Contents/Developer/usr/bin/Rez - Fatal Error, can't recover. AUResources.r: ### /Applications/Dev/Xcode.app/Contents/Developer/usr/bin/Rez - Since errors occurred, /Users/kurt6string/Library/Developer/Xcode/DerivedData/StageMidi-auhrzivhyvindzbpacwchjysorec/Build/Intermediates/StageMidi.build/Debug/StageMidi.build/ResourceManagerResources/Objects/juce_AU_Resources.rsrc's resource fork was not written. Command /Applications/Dev/Xcode.app/Contents/Developer/usr/bin/Rez failed with exit code 3


#2

I’m learning some things here…Apparently xcode used to come bundled with the audio utilities and it doesn’t anymore, they have to be downloaded separately. And it appears the xcode command line tools have to be installed as well. I’m trying all this crud out now and will report back later. It’s been a normal (frustrating) day with the new tools…so be it.


#3

same situation here.
Seems they cut somethings.
what should we do now?


#4

ok, after I downloaded the audio tools just now, i found the solution
http://www.rawmaterialsoftware.com/viewtopic.php?f=8&t=8682


#5

I’ve made some progress but this whole xcode 4.3 and modularized-juce-audio plugins zone has been no fun at all.

What I’ve learned is:

After installing the newest version of xcode (4.3.1) you must also install the command line tools and the XCode Audio tools. Then, inside the xcode.app contents you add the Extras folder to the Developers folder and copy the audio tools CoreAudio folder into it. After that you try building the stock juce plugin demo. It won’t compile however until you use a texteditor to fix various casting issues. If you try doing this in xcode it will lockup. I had to let xcode’s editor ‘fix’ the problem (since I didn’t really understand what it was complaining about), then copy the change into the offending file using the texteditor and then force quitting xcode and restarting it in order to move onto the next compilation glitch (we’re editing apple files here btw, not juce files). Iterate over this 4 or 5 times until the plugin demo compiles. At this point you should have the JuceDemoPlugin.component and .vst in the ~/Library… folder, which should be found by the audio host.

The next problem I encountered was that the plugin I really want to compile is only concerned with midi, it has no audio in’s-n-outs’. After hours of trying I was unable to convince the audounit version of the plugin to give me just a single midi in and midi out. But…the vst version did.

Unfortunately, the plugin editor is now suffering from ‘whiteout’ - I see it paint once (briefly) and then it just turns white and I have no solution for this. Other plugin editors work fine, only the juce plugins are exhibiting this behavior, both the stock audio plugin demo and my own.

I have used the new introjucer to create the plugin project and copied my four source files into it, but it suffers from whiteout on the plugin gui also. I’m going back to do battle with the beast again after I take some aspirin…


#6

Hi Kurt,

I wondered if you made any progress with this issue? 2 things really:

1 -How you were able to convince the vst version of the plugin to give you just a single midi in and midi out? I too want my plugin to handle just MIDI data. Did you ever get the AU working with Juce and a MIDI effect?

2 - I came across your post as I have error messages including ‘failed to find AUResources/AUResources.r’ and ‘failed to find CoreServices/CoreServices.r’…‘Command /Applications/Xcode.app/Contents/Developer/usr/bin/Rez failed with exit code 3’. Any tips on these issues would be really appreciated also.

I know it was a long time ago but I’d love any help you can offer.

Thanks in advance,

Dave


#7

Hi Kurk,

Just so I am not wasting your time, I solved 2 (above) but would still appreciate any tips or advice on writing a MIDI plugin.

Cheers