Removal of toolbar items during customization works only onc


#1

Hi all,

I have a problem on Windows regarding the toolbar customization. I haven’t tried it in on Linux or Mac OS yet. To reproduce the problem, build the JUCE demo of JUCE 1.50 or 1.52 (haven’t tried 1.51) and activate the widget demo. Then select “Customize…” and remove the first icon. After that you can’t drag any toolbar items of the toolbar, until you close the customization dialog and reopen it again.

I tried to solve the problem myself, but couldn’t as I don’t understand the inner workings of the JUCE message pump. As far as I can see, after the removal of the first toolbar item, no mouse down events get through to the toolbar items and because of that no dragging operations can start. Mouse click events on the dialog get through though.

It would be great if someone could help me out here.

Thanks,
Marcus


#2

This is a really nasty one! Seems to be a windows-only problem, caused by win32 not allowing unfocused windows to receive any mouse-down events… I’ll figure out some kind of workaround and check some code in later today…


#3

Hi Jules,

that would be great. It will also be interesting to see how you work around the problem.

Thanks a lot for your efforts :slight_smile:

Marcus


#4

Hi Jules,

Many thanks for your fast support and fix. It works great :slight_smile:

Cheers,
Marcus