Replace all include guard macros

Currently JUCE include guard macros look like JUCE_RANDOMACCESSFILE_JUCEHEADER

This goes against the specifications. User defined identifiers should not start with an underscore, or worse a double underscore. I suggest JUCE_RANDOMACCESSFILE_H_INCLUDED since this is the boost style. It also reads better when you use it in a conditional compilation expression:

// some code that depends on RandomAccessFile being available

Yes, I like that! They’re almost all auto-generated, so when I get a moment, I’ll update the generator for that. Thanks for the heads-up!

Hard to imagine that after 7 years, significant improvements are still possible in the core code!!

Isn’t “#pragma once” essentially universal now?


  1. All #pragma directives are essentially non-standard (as per the spec)

  2. A macro allows other code to know if a particular header has been included (unlike the usage of #pragma