Resizable AU


#1

Hi, not sure whether this is with the recent move to JUCE 5, but my AU is now showing a resize box where as it wasn’t before:

Has this behaviour changed at all as I don’t want the user to be able to resize…

thanks


#2

https://github.com/WeAreROLI/JUCE/commit/a0259ce408bf5aca7e886b7a67c7f639b47eb1f5

and

https://github.com/WeAreROLI/JUCE/commit/70f4b0d5dc7ab3f0d9745b8377cbf3c2a8043157

Rail


#3

thanks - so the default behaviour has changed then…


#4

Yes

Rail


#5

doesn’t appear to be having any effect for me. does the setResizable(false) call need to be made at a certain point in the creation of the editor? I’ve tried calling it directly after creating the editor and then also at points later on and it’s still resizeable…


#6

Are you also building the AUv3 version of the plug-in?

Logic’s Behaviour is a bit strange with AUv3: it will always add the dropdown menu if it loads the AUv3 version of the plug-in. But the drop-down menu doesn’t actually resize the view: it just zooms. I tried this with Apple’s own AUv3 filter example and you get the same result.

Also, sometimes, even if it loads the AUv2 version, it still shows the drop-down menu if you haven’t re-scanned your plug-ins after you removed the AUv3 version.


#7

yes, building both, and yes - that’s the behaviour - it just zooms and so everything gets out of sync and stops working.

i’m building the auv3 as it’s required for the standalone (still, I believe?) - if this isn’t the case then I can try removing the auv3 from the build (which would also fix my iOS problem below)

didn’t used to have this issue though, have only noticed it before the move to 5 - before that I had no zoom box…

whilst we’re on the subject is there any way to tailor the components per architecture, e.g. i don’t want to build the auv3 for the iOS build, but I do want to build it for the MacOS build…


#8

Yeah, this also happens with Apple’s AUv3 examples and some other non JUCE AUv3s. Looks like a Logic bug to me.

The auv3 is not required for the standalone build. Just disable the AUv3 plug-in format in the Projucer:

This is currently not possible. But you could add a post-build script that deletes the AUv3 app extension from inside the standalone bundle.


#9

thx - didn’t think so, but just checking… looks like I can do away with the AUv3 entirely though - will give this a go… thanks


#10

brilliant - removed the AUv3 and the resizing has disappeared and also the plugin has gone back to being mono & stereo…!


#11

See other thread: