Right click on hosted VST3 plugin parameter crashes Juce Host


we are using JUCE to host plugins. When hosting some VST3 plugins on the Mac (Intel and Apple Silicon) and we right click on a parameter on the hosted plugins it crashes our host.
To validate, we tried it in the JUCE example host app and the same behavior occurs.

This does not happen when hosting the same VST2 and AU plugins, only with VST3.

The debugger does not reveal any info as the exception comes from the hosted plugin.
Hosting the same VST3 plugins in DAWs (Ableton, Cubase, Reaper) do not have this problem and right clicking works normally.

To try it out, here are some VST3 plugins that show this behavior are:

  1. Many Plugin Alliance plugins (ie Focusrite Console)
  2. Analog Obsession MaxBax
  3. TBProAudio GSat

The crash occurs only when right clicking on a parameter on the VST3 hosted plugin, not anywhere else.

Any help would be greatly appreciated!

We are using JUCE 7.0.5 and it happens in the example host app of JUCE 7.0.7.
We went back to our releases from almost 2 years ago (when using J 6.0.5) and the problem is still occurring.

You can reproduce the issue with GSat Plus, download for free from:

Here is what the debugger shows when using the JUCE example host app

Thanks for reporting, that’s fixed on develop here:


Yes, that solved the problem!
Thank you very much :heart_eyes: :100: