RTAS compilation issue PT 90 SDK


#1

Hi all, having a compilation issue trying to get a plug up and running on RTAS SDK (9.0):


1>------ Build started: Project: DiracLiveRTAS, Configuration: Debug Win32 ------
1>  juce_RTAS_DigiCode3.cpp
1>C:\Users\robi\code\svn\DLRCS\trunk\TestProject\Common\PT_SDK\pt90sdk\AlturaPorts\AlturaSource\PPC_H\Processes.h(261): error C2733: 'GetProcessInformation' : second C linkage of overloaded function not allowed
1>          C:\Program Files (x86)\Windows Kits\8.0\Include\um\winbase.h(2905) : see declaration of 'GetProcessInformation'
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Anyone got an idea how to resolve this ? The obvious one (to define EXCLUDE_MAC_TOOLBOX) met with an #error :(

/Rob

Edit: BTW, this happens with an IntroJucer created plug also, with PT 90 SDK.


#2

juce_RTAS_DigiCode3.cpp needs to have _WIN32_WINNT=0x0601 defined, with 0x0602 this happens.


#3

hi robiwan,

same problem here !

i tried building an "Introjucer-created" RTAS plugin with Visual Studio 2013 Community and PT90SDK.

unfortunately i got the same error and to be honest, i don't understand your solution you mentioned above,
since in my version of juce_RTAS_DigiCode3.cpp there is no _WIN32_WINNT at all ...

the only way i managed to build an rtas was with Visual Studio 2008 and PT 80 SDK (not 90 !).

 

so, it'd REALLY nice if you could share some more infos how you did it:

- which version of visual studio did you use to compile your plugin ?

- which version of visual studio did you use to compile "PluginLib" ?

- which version of juce do you have ?

- could you be a little more specific, what you did to get it all working ?
  (especially regarding that _WIN32_WINNT thing)

 

thanks in advance,

matthias

 

 


#4

Apperantly it seems since RTAS SDK is "old" it looks for some values from "legacy" toolkits.

In my case setting Platform Toolset to v120_xp resolved the issue.